{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-107318 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-107318 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-107318 is a high-severity vulnerability in @fastify/reply-from, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-107318 and fix it if it is affected.\n\nWhat it is: CVE-2026-107318 is a high-severity vulnerability in @fastify/reply-from, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-107318 in the wild and no public exploit code.\n\nAffected product: @fastify/reply-from. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-107318/ (Markdown: https://insights.sbomify.com/CVE-2026-107318/index.md)","id":"CVE-2026-107318","markdown":"https://insights.sbomify.com/CVE-2026-107318/index.md","name":"CVE-2026-107318","record":{"aliases":["GHSA-j425-jw94-m29r"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Fastify proxy plugin","requires_auth":"none","summary":"An on-path attacker can impersonate HTTPS upstreams and intercept or forge traffic because the plugin disables TLS certificate validation by default.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"openjs","cpe":[],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"@fastify/reply-from is a Fastify plugin that forwards requests to an upstream HTTP or HTTPS server. In versions prior to 12.7.0, all of the built-in HTTPS transports override the secure default and set rejectUnauthorized to false, so the proxy does not verify the TLS certificate of the upstream even when the application points it at an https upstream in the default configuration. An on-path network attacker can therefore impersonate the configured HTTPS upstream, read the credentials and request bodies the proxy forwards, and return forged responses that the application trusts. The issue is fixed in @fastify/reply-from 12.7.0, and users should upgrade to 12.7.0 or later. As a workaround, pass an explicit rejectUnauthorized true on the transport, supply an already configured undici instance, or use the undici global agent.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"@fastify/reply-from vulnerable to improper certificate validation in built-in HTTPS transports","id":"CVE-2026-107318","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"weak_cryptography","year":"2026"},"n_packages":0,"n_references":2,"next":{"headline":"GamiPress \u003c 8.0.6 - Subscriber+ Activity Log Disclosure","id":"CVE-2026-107319"},"packages":[],"prev":{"headline":"This CVE ID has been rejected or withdrawn by its CVE Numbering Authority.","id":"CVE-2026-107316"},"products":["@fastify/reply-from"],"published":"2026-10-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-09","vendors":["@fastify/reply-from"]},"summary":"An on-path attacker can impersonate HTTPS upstreams and intercept or forge traffic because the plugin disables TLS certificate validation by default.","url":"https://insights.sbomify.com/CVE-2026-107318/"}