# CVE-2026-107318: @fastify/reply-from vulnerable to improper certificate validation in built-in HTTPS transports

> An on-path attacker can impersonate HTTPS upstreams and intercept or forge traffic because the plugin disables TLS certificate validation by default.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 Oct 2026
- **Updated:** 9 Oct 2026
- **Also known as:** GHSA-j425-jw94-m29r

## What is CVE-2026-107318?

CVE-2026-107318 is a high-severity vulnerability in @fastify/reply-from, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@fastify/reply-from is a Fastify plugin that forwards requests to an upstream HTTP or HTTPS server. In versions prior to 12.7.0, all of the built-in HTTPS transports override the secure default and set rejectUnauthorized to false, so the proxy does not verify the TLS certificate of the upstream even when the application points it at an https upstream in the default configuration. An on-path network attacker can therefore impersonate the configured HTTPS upstream, read the credentials and request bodies the proxy forwards, and return forged responses that the application trusts. The issue is fixed in @fastify/reply-from 12.7.0, and users should upgrade to 12.7.0 or later. As a workaround, pass an explicit rejectUnauthorized true on the transport, supply an already configured undici instance, or use the undici global agent.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-107318?


## How do I fix CVE-2026-107318?

No fix has been published for CVE-2026-107318 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-107318 being exploited?

There is no known exploitation of CVE-2026-107318 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-107318 and fix it if it is affected.

What it is: CVE-2026-107318 is a high-severity vulnerability in @fastify/reply-from, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-107318 in the wild and no public exploit code.

Affected product: @fastify/reply-from. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-107318/ (Markdown: https://insights.sbomify.com/CVE-2026-107318/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-107318
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-107318
- OSV: https://osv.dev/vulnerability/CVE-2026-107318

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-107318/
Summaries are generated and may contain mistakes; the official description above is the record.
