# CVE-2026-107322: OS command injection in Amazon Agent Plugins for AWS databases-on-aws

> Remote unauthenticated attackers can execute arbitrary OS commands on the host via crafted database inputs in the AWS databases-on-aws plugin.

- **Severity:** High 8.5 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 8 Oct 2026
- **Updated:** 8 Oct 2026

## What is CVE-2026-107322?

CVE-2026-107322 is a high-severity command injection vulnerability in databases-on-aws, published on 8 Oct 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

An incomplete list of disallowed inputs in Amazon Agent Plugins for AWS databases-on-aws plugin before 1.7.1 might allow a remote unauthenticated actor to execute arbitrary operating system commands on the host running the helper via a crafted database command value introduced in the agent context.

To remediate this issue, users should upgrade to databases-on-aws plugin version 1.7.1 or later and verify that the updated plugin is active in each environment where it is used.

Weakness: CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2026-107322?


## How do I fix CVE-2026-107322?

No fix has been published for CVE-2026-107322 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-107322 being exploited?

There is no known exploitation of CVE-2026-107322 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-107322 and fix it if it is affected.

What it is: CVE-2026-107322 is a high-severity command injection vulnerability in databases-on-aws, published on 8 Oct 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-107322 in the wild and no public exploit code.

Affected product: databases-on-aws. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-107322/ (Markdown: https://insights.sbomify.com/CVE-2026-107322/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-107322
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-107322
- OSV: https://osv.dev/vulnerability/CVE-2026-107322

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-107322/
Summaries are generated and may contain mistakes; the official description above is the record.
