{"answers":{"affected":"1 open source package ship an affected version, including pgbouncer.","exploited":"There is no known exploitation of CVE-2026-107348 in the wild and no public exploit code.","fix":"Upgrade pgbouncer to 1.26.1 or later.","what":"CVE-2026-107348 is a medium-severity vulnerability in PgBouncer, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-107348 and fix it if it is affected.\n\nWhat it is: CVE-2026-107348 is a medium-severity vulnerability in PgBouncer, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-107348 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pgbouncer (Bitnami): affected from 1.21.0; fixed in 1.26.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-107348/ (Markdown: https://insights.sbomify.com/CVE-2026-107348/index.md)","id":"CVE-2026-107348","markdown":"https://insights.sbomify.com/CVE-2026-107348/index.md","name":"CVE-2026-107348","record":{"aliases":["AZL-108195","BIT-pgbouncer-2026-107348","DEBIAN-CVE-2026-107348","ECHO-5e11-e26f-413f","GHSA-982p-g5h4-w372","UBUNTU-CVE-2026-107348"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"PostgreSQL connection pooler","requires_auth":"none","summary":"Remote attackers can cause denial of service via integer overflow in PgBouncer when max_packet_size is set above 2GB, stalling all connections.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"PostgreSQL","cpe":[],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-835","name":"Loop with Unreachable Exit Condition"},{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"Integer overflow in the message buffer growth logic (mbuf_make_room) in PgBouncer 1.21.0 through 1.26.0 allows a remote attacker to cause a denial of service when max_packet_size is configured above 2147483648. A packet header declaring a length above 2^31 makes the buffer size computation overflow, leaving the growth loop unable to terminate. Because PgBouncer serves all clients from a single process, this saturates a CPU core and stalls every pooled connection until the process is restarted. Since 1.23.0 the overflow is reachable before authentication with a five-byte packet header.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Integer overflow causes an infinite loop in message buffer growth in PgBouncer","id":"CVE-2026-107348","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"integer_overflow","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Infinite loop on empty option name in startup options parameter in PgBouncer","id":"CVE-2026-107349"},"packages":[{"ecosystem":"Bitnami","fixed":["1.26.1"],"introduced":["1.21.0"],"last_affected":[],"package":"pgbouncer","purl":"pkg:bitnami/pgbouncer","source":"BIT-pgbouncer-2026-107348"}],"prev":{"headline":"Nomad dispatch payload writes can escape the allocation directory through symlinks","id":"CVE-2026-107347"},"products":["PgBouncer"],"published":"2026-10-14","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-16","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service via integer overflow in PgBouncer when max_packet_size is set above 2GB, stalling all connections.","url":"https://insights.sbomify.com/CVE-2026-107348/"}