# CVE-2026-107348: Integer overflow causes an infinite loop in message buffer growth in PgBouncer

> Remote attackers can cause denial of service via integer overflow in PgBouncer when max_packet_size is set above 2GB, stalling all connections.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2026
- **Updated:** 16 Oct 2026
- **Also known as:** AZL-108195, BIT-pgbouncer-2026-107348, DEBIAN-CVE-2026-107348, ECHO-5e11-e26f-413f, GHSA-982p-g5h4-w372, UBUNTU-CVE-2026-107348

## What is CVE-2026-107348?

CVE-2026-107348 is a medium-severity vulnerability in PgBouncer, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Integer overflow in the message buffer growth logic (mbuf_make_room) in PgBouncer 1.21.0 through 1.26.0 allows a remote attacker to cause a denial of service when max_packet_size is configured above 2147483648. A packet header declaring a length above 2^31 makes the buffer size computation overflow, leaving the growth loop unable to terminate. Because PgBouncer serves all clients from a single process, this saturates a CPU core and stalls every pooled connection until the process is restarted. Since 1.23.0 the overflow is reachable before authentication with a five-byte packet header.

Weakness: CWE-835 (Loop with Unreachable Exit Condition), CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-107348?

1 open source package ship an affected version, including pgbouncer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pgbouncer` | Bitnami | From 1.21.0 | 1.26.1 |

## How do I fix CVE-2026-107348?

Upgrade pgbouncer to 1.26.1 or later.

## Is CVE-2026-107348 being exploited?

There is no known exploitation of CVE-2026-107348 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-107348 and fix it if it is affected.

What it is: CVE-2026-107348 is a medium-severity vulnerability in PgBouncer, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-107348 in the wild and no public exploit code.

Affected packages and fixed versions:
- pgbouncer (Bitnami): affected from 1.21.0; fixed in 1.26.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-107348/ (Markdown: https://insights.sbomify.com/CVE-2026-107348/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-107348
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-107348
- OSV: https://osv.dev/vulnerability/CVE-2026-107348

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-107348/
Summaries are generated and may contain mistakes; the official description above is the record.
