# CVE-2026-107349: Infinite loop on empty option name in startup options parameter in PgBouncer

> An unauthenticated remote attacker can cause a denial of service in PgBouncer by sending a startup message with an empty option name, leading to an infinite loop.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2026
- **Updated:** 16 Oct 2026
- **Also known as:** AZL-108192, BIT-pgbouncer-2026-107349, DEBIAN-CVE-2026-107349, ECHO-7592-aec9-5cd1, GHSA-h8cj-p2h5-hm79, UBUNTU-CVE-2026-107349

## What is CVE-2026-107349?

CVE-2026-107349 is a high-severity denial of service vulnerability in PgBouncer, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An infinite loop in PgBouncer 1.20.0 through 1.26.0 allows an unauthenticated remote attacker to cause a denial of service. A StartupMessage whose options parameter contains an empty parameter name, such as "-c=", makes the ignore_startup_parameters list lookup loop forever. Because PgBouncer serves all clients from a single process, this saturates a CPU core and makes PgBouncer unresponsive to all clients until the process is restarted.

Weakness: CWE-835 (Loop with Unreachable Exit Condition), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-107349?

1 open source package ship an affected version, including pgbouncer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pgbouncer` | Bitnami | From 1.20.0 | 1.26.1 |

## How do I fix CVE-2026-107349?

Upgrade pgbouncer to 1.26.1 or later.

## Is CVE-2026-107349 being exploited?

There is no known exploitation of CVE-2026-107349 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-107349 and fix it if it is affected.

What it is: CVE-2026-107349 is a high-severity denial of service vulnerability in PgBouncer, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-107349 in the wild and no public exploit code.

Affected packages and fixed versions:
- pgbouncer (Bitnami): affected from 1.20.0; fixed in 1.26.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-107349/ (Markdown: https://insights.sbomify.com/CVE-2026-107349/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-107349
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-107349
- OSV: https://osv.dev/vulnerability/CVE-2026-107349

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-107349/
Summaries are generated and may contain mistakes; the official description above is the record.
