# CVE-2026-107350: Authentication bypass via second StartupMessage during SCRAM authentication in PgBouncer

> Remote attackers can bypass authentication to log in as any user, including admins, by exploiting a flaw in SCRAM authentication handling.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2026
- **Updated:** 16 Oct 2026
- **Also known as:** AZL-108189, BIT-pgbouncer-2026-107350, DEBIAN-CVE-2026-107350, ECHO-67d6-1d9f-3ccf, GHSA-qcxp-3cx5-3f3g, UBUNTU-CVE-2026-107350

## What is CVE-2026-107350?

CVE-2026-107350 is a high-severity authentication bypass vulnerability in PgBouncer, published on 14 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper authentication in PgBouncer 1.17.0 through 1.26.0 allows a remote attacker who knows the password of a user listed in auth_file to log in as any other user that authenticates using SCRAM, including PgBouncer admin users and backend superusers. A second StartupMessage sent during SCRAM authentication against a non-existent database is not rejected and switches the user being logged in as, while the SCRAM exchange is still verified against the keys of the first user.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-107350?

1 open source package ship an affected version, including pgbouncer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pgbouncer` | Bitnami | From 1.17.0 | 1.26.1 |

## How do I fix CVE-2026-107350?

Upgrade pgbouncer to 1.26.1 or later.

## Is CVE-2026-107350 being exploited?

There is no known exploitation of CVE-2026-107350 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-107350 and fix it if it is affected.

What it is: CVE-2026-107350 is a high-severity authentication bypass vulnerability in PgBouncer, published on 14 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-107350 in the wild and no public exploit code.

Affected packages and fixed versions:
- pgbouncer (Bitnami): affected from 1.17.0; fixed in 1.26.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-107350/ (Markdown: https://insights.sbomify.com/CVE-2026-107350/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-107350
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-107350
- OSV: https://osv.dev/vulnerability/CVE-2026-107350

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-107350/
Summaries are generated and may contain mistakes; the official description above is the record.
