{"answers":{"affected":"2 open source packages ship an affected version, including webonyx/graphql-php.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-107376 exists.","fix":"Upgrade webonyx/graphql-php to 15.32.3 or later.","what":"CVE-2026-107376 is a high-severity denial of service vulnerability in webonyx graphql-php, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-107376 and fix it if it is affected.\n\nWhat it is: CVE-2026-107376 is a high-severity denial of service vulnerability in webonyx graphql-php, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-107376 exists.\n\nAffected packages and fixed versions:\n- webonyx/graphql-php (Packagist): affected all versions; fixed in 15.32.3\n- webonyx/graphql-php (Packagist): affected all versions; fixed in 15.32.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-107376/ (Markdown: https://insights.sbomify.com/CVE-2026-107376/index.md)","id":"CVE-2026-107376","markdown":"https://insights.sbomify.com/CVE-2026-107376/index.md","name":"CVE-2026-107376","record":{"aliases":["GHSA-r7cg-qjjm-xhqq"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP GraphQL library","requires_auth":"none","summary":"Remote attackers can crash PHP processes by submitting deeply nested GraphQL queries, causing stack overflow before validation occurs.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"webonyx graphql-php is a PHP implementation of the GraphQL specification. Prior to 15.32.3, GraphQL\\Language\\Parser performs recursive descent without a recursion limit in parseSelectionSet, parseValueLiteral, and parseTypeReference. A remote attacker can submit deeply nested selection sets, object or list values, or list types that exhaust the PHP process stack during pre-validation parsing, before query validation and complexity controls run. The resulting SIGSEGV can terminate PHP-FPM workers or long-running Swoole, RoadRunner, ReactPHP, or CLI processes and cannot be caught by application-level exception handling. This issue is fixed in version 15.32.3.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"webonyx graphql-php: Unbounded recursion in parser causes stack overflow on crafted nested input","id":"CVE-2026-107376","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"datamodel-code-generator: Protobuf weak-import path traversal allows files to be written outside the temporary directory","id":"CVE-2026-107377"},"packages":[{"ecosystem":"Packagist","fixed":["15.32.3"],"introduced":["0"],"last_affected":[],"package":"webonyx/graphql-php","purl":null,"source":"GHSA-r7cg-qjjm-xhqq"},{"ecosystem":"Packagist","fixed":["15.32.3"],"introduced":["0"],"last_affected":[],"package":"webonyx/graphql-php","purl":"pkg:composer/webonyx/graphql-php","source":"GHSA-r7cg-qjjm-xhqq"}],"prev":{"headline":"JHipster: SQL Injection in the Parameter of JHipster-Generated Reactive (WebFlux + R2DBC) Applicationssort","id":"CVE-2026-107375"},"products":["graphql-php"],"published":"2026-10-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["webonyx"]},"summary":"Remote attackers can crash PHP processes by submitting deeply nested GraphQL queries, causing stack overflow before validation occurs.","url":"https://insights.sbomify.com/CVE-2026-107376/"}