# CVE-2026-107376: webonyx graphql-php: Unbounded recursion in parser causes stack overflow on crafted nested input

> Remote attackers can crash PHP processes by submitting deeply nested GraphQL queries, causing stack overflow before validation occurs.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 Oct 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-r7cg-qjjm-xhqq

## What is CVE-2026-107376?

CVE-2026-107376 is a high-severity denial of service vulnerability in webonyx graphql-php, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

webonyx graphql-php is a PHP implementation of the GraphQL specification. Prior to 15.32.3, GraphQL\Language\Parser performs recursive descent without a recursion limit in parseSelectionSet, parseValueLiteral, and parseTypeReference. A remote attacker can submit deeply nested selection sets, object or list values, or list types that exhaust the PHP process stack during pre-validation parsing, before query validation and complexity controls run. The resulting SIGSEGV can terminate PHP-FPM workers or long-running Swoole, RoadRunner, ReactPHP, or CLI processes and cannot be caught by application-level exception handling. This issue is fixed in version 15.32.3.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-107376?

2 open source packages ship an affected version, including webonyx/graphql-php.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `webonyx/graphql-php` | Packagist | All versions | 15.32.3 |
| `webonyx/graphql-php` | Packagist | All versions | 15.32.3 |

## How do I fix CVE-2026-107376?

Upgrade webonyx/graphql-php to 15.32.3 or later.

## Is CVE-2026-107376 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-107376 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-107376 and fix it if it is affected.

What it is: CVE-2026-107376 is a high-severity denial of service vulnerability in webonyx graphql-php, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-107376 exists.

Affected packages and fixed versions:
- webonyx/graphql-php (Packagist): affected all versions; fixed in 15.32.3
- webonyx/graphql-php (Packagist): affected all versions; fixed in 15.32.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-107376/ (Markdown: https://insights.sbomify.com/CVE-2026-107376/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-107376
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-107376
- OSV: https://osv.dev/vulnerability/CVE-2026-107376

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-107376/
Summaries are generated and may contain mistakes; the official description above is the record.
