CVE-2026-107382 MariaDB Connector/Node.js: Uncaught exception crashes the client during ed25519 authentication with zero-configuration TLS

Medium 5.9 Published Updated

A network attacker can crash the Node.js client by triggering an uncaught exception during ed25519 authentication with zero-configuration TLS.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-107382?

CVE-2026-107382 is a medium-severity denial of service vulnerability in mariadb-corporation mariadb-connector-nodejs, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

MariaDB Connector/Node.js is used to connect applications developed on Node.js to MariaDB and MySQL databases. From 3.3.0 until 3.5.4, the zero-configuration TLS fingerprint-validation path calls Ed25519PasswordAuth.hash() through Authentication.validateFingerPrint, but Ed25519PasswordAuth.hash() references a seed identifier that is not in scope. Exposure requires a MariaDB server reached over TCP, TLS enabled with ssl: true or an ssl object whose rejectUnauthorized value is not false, a password set, no ssl.ca configured, and client_ed25519 negotiated as the authentication plugin. Under those conditions, a legitimate server, malicious server, or network attacker presenting a self-signed certificate can reach this path and cause a synchronous ReferenceError to escape the socket data handler. Under Node.js default uncaught-exception behavior, the client process terminates, causing denial of service. Configurations using a provided CA, rejectUnauthorized: false, another authentication plugin, or a Unix socket do not reach this vulnerable path. This issue is fixed in version 3.5.4.

Weakness: CWE-248

Which versions are affected by CVE-2026-107382?

5 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client.

PackageAffectedFixed in
mariadb BitnamiFrom 3.3.03.5.4
mariadb npmFrom 3.3.03.5.4
mariadb npmFrom 3.3.03.5.4
mariadb-min BitnamiFrom 3.3.03.5.4
mysql-client BitnamiFrom 3.3.03.5.4

How do I fix CVE-2026-107382?

Upgrade mariadb to 3.5.4 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-107382 being exploited?

There is no known exploitation of CVE-2026-107382 in the wild and no public exploit code.

Sources

Also known as BIT-mariadb-2026-107382, BIT-mariadb-min-2026-107382, BIT-mysql-client-2026-107382, GHSA-cx2f-j9fh-8g68.

Is CVE-2026-107382 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free