# CVE-2026-107382: MariaDB Connector/Node.js: Uncaught exception crashes the client during ed25519 authentication with zero-configuration TLS

> A network attacker can crash the Node.js client by triggering an uncaught exception during ed25519 authentication with zero-configuration TLS.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2026
- **Updated:** 8 Oct 2026
- **Also known as:** BIT-mariadb-2026-107382, BIT-mariadb-min-2026-107382, BIT-mysql-client-2026-107382, GHSA-cx2f-j9fh-8g68

## What is CVE-2026-107382?

CVE-2026-107382 is a medium-severity denial of service vulnerability in mariadb-corporation mariadb-connector-nodejs, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MariaDB Connector/Node.js is used to connect applications developed on Node.js to MariaDB and MySQL databases. From 3.3.0 until 3.5.4, the zero-configuration TLS fingerprint-validation path calls Ed25519PasswordAuth.hash() through Authentication.validateFingerPrint, but Ed25519PasswordAuth.hash() references a seed identifier that is not in scope. Exposure requires a MariaDB server reached over TCP, TLS enabled with ssl: true or an ssl object whose rejectUnauthorized value is not false, a password set, no ssl.ca configured, and client_ed25519 negotiated as the authentication plugin. Under those conditions, a legitimate server, malicious server, or network attacker presenting a self-signed certificate can reach this path and cause a synchronous ReferenceError to escape the socket data handler. Under Node.js default uncaught-exception behavior, the client process terminates, causing denial of service. Configurations using a provided CA, rejectUnauthorized: false, another authentication plugin, or a Unix socket do not reach this vulnerable path. This issue is fixed in version 3.5.4.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-107382?

5 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mariadb` | Bitnami | From 3.3.0 | 3.5.4 |
| `mariadb` | npm | From 3.3.0 | 3.5.4 |
| `mariadb` | npm | From 3.3.0 | 3.5.4 |
| `mariadb-min` | Bitnami | From 3.3.0 | 3.5.4 |
| `mysql-client` | Bitnami | From 3.3.0 | 3.5.4 |

## How do I fix CVE-2026-107382?

Upgrade mariadb to 3.5.4 or later.

## Is CVE-2026-107382 being exploited?

There is no known exploitation of CVE-2026-107382 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-107382 and fix it if it is affected.

What it is: CVE-2026-107382 is a medium-severity denial of service vulnerability in mariadb-corporation mariadb-connector-nodejs, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-107382 in the wild and no public exploit code.

Affected packages and fixed versions:
- mariadb (Bitnami): affected from 3.3.0; fixed in 3.5.4
- mariadb (npm): affected from 3.3.0; fixed in 3.5.4
- mariadb (npm): affected from 3.3.0; fixed in 3.5.4
- mariadb-min (Bitnami): affected from 3.3.0; fixed in 3.5.4
- mysql-client (Bitnami): affected from 3.3.0; fixed in 3.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-107382/ (Markdown: https://insights.sbomify.com/CVE-2026-107382/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-107382
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-107382
- OSV: https://osv.dev/vulnerability/CVE-2026-107382

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-107382/
Summaries are generated and may contain mistakes; the official description above is the record.
