CVE-2026-107383 MariaDB Connector/Node.js exposes uninitialized process memory through malformed GeoJSON parameters
A vulnerability in MariaDB Connector/Node.js allows attackers to disclose uninitialized heap memory, potentially exposing sensitive data like credentials or session tokens.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-107383?
CVE-2026-107383 is a high-severity vulnerability in mariadb-corporation mariadb-connector-nodejs, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
MariaDB Connector/Node.js is used to connect applications developed on Node.js to MariaDB and MySQL databases. Prior to 3.2.5, 3.3.4, 3.4.7, and 3.5.4, the GeoJSON Polygon and MultiPolygon binary encoders size a Buffer.allocUnsafe() allocation from each ring's numeric length before confirming that the ring is an array. A malformed non-array ring can therefore reserve bytes that the writing loop skips, and the connector sends the full buffer through execute() or batch(), disclosing uninitialized Node.js heap data into a database value. The persisted data can include other users' content, session material, database credentials, or TLS key material and may propagate to backups and replicas. The text-protocol query() path is not affected. This issue is fixed in versions 3.2.5, 3.3.4, 3.4.7, and 3.5.4.
Weakness: CWE-200
Which versions are affected by CVE-2026-107383?
11 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | All versions | 3.2.5, 3.3.4, 3.4.7, 3.5.4 |
mariadb npm | All versions | 3.2.5 |
mariadb npm | All versions | 3.2.5 |
mariadb npm | From 3.3.0 | 3.3.4 |
mariadb npm | From 3.3.0 | 3.3.4 |
mariadb npm | From 3.4.0 | 3.4.7 |
5 more packages
mariadb npm | From 3.4.0 | 3.4.7 |
mariadb npm | From 3.5.0-rc.0 | 3.5.4 |
mariadb npm | From 3.5.0-rc.0 | 3.5.4 |
mariadb-min Bitnami | All versions | 3.2.5, 3.3.4, 3.4.7, 3.5.4 |
mysql-client Bitnami | All versions | 3.2.5, 3.3.4, 3.4.7, 3.5.4 |
How do I fix CVE-2026-107383?
Upgrade mariadb to a fixed version for your release line: 3.2.5, 3.3.4, 3.4.7 or 3.5.4.
Is CVE-2026-107383 being exploited?
There is no known exploitation of CVE-2026-107383 in the wild and no public exploit code.
Sources
Also known as BIT-mariadb-2026-107383, BIT-mariadb-min-2026-107383, BIT-mysql-client-2026-107383, GHSA-48qf-xh34-q73r.