CVE-2026-107385 MariaDB Connector/Node.js: SQL injection in the text protocol when the session uses NO_BACKSLASH_ESCAPES
SQL injection in MariaDB Connector/Node.js allows attackers to execute arbitrary SQL when NO_BACKSLASH_ESCAPES mode is enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-107385?
CVE-2026-107385 is a high-severity SQL injection vulnerability in mariadb-corporation mariadb-connector-nodejs, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
MariaDB Connector/Node.js is used to connect applications developed on Node.js to MariaDB and MySQL databases. Prior to 3.2.5, 3.3.4, 3.4.7, and 3.5.4, text-protocol escaping always prefixes quotes with a backslash and does not honor the session's NO_BACKSLASH_ESCAPES mode, including in Connection.escape(). When that mode is enabled, the backslash is an ordinary character, so an attacker-controlled placeholder value can close the SQL string literal and inject arbitrary SQL with the application's database privileges. The vulnerable configuration may be enabled server-wide, through connector initialization options, or with an application-issued SET sql_mode; execute() and batch() use binary protocols and are not affected. This issue is fixed in versions 3.2.5, 3.3.4, 3.4.7, and 3.5.4.
Weakness: CWE-89
Which versions are affected by CVE-2026-107385?
11 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | All versions | 3.2.5, 3.3.4, 3.4.7, 3.5.4 |
mariadb npm | All versions | 3.2.5 |
mariadb npm | All versions | 3.2.5 |
mariadb npm | From 3.3.0 | 3.3.4 |
mariadb npm | From 3.3.0 | 3.3.4 |
mariadb npm | From 3.4.0 | 3.4.7 |
5 more packages
mariadb npm | From 3.4.0 | 3.4.7 |
mariadb npm | From 3.5.0-rc.0 | 3.5.4 |
mariadb npm | From 3.5.0-rc.0 | 3.5.4 |
mariadb-min Bitnami | All versions | 3.2.5, 3.3.4, 3.4.7, 3.5.4 |
mysql-client Bitnami | All versions | 3.2.5, 3.3.4, 3.4.7, 3.5.4 |
How do I fix CVE-2026-107385?
Upgrade mariadb to a fixed version for your release line: 3.2.5, 3.3.4, 3.4.7 or 3.5.4.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2026-107385 being exploited?
There is no known exploitation of CVE-2026-107385 in the wild and no public exploit code.
Sources
Also known as BIT-mariadb-2026-107385, BIT-mariadb-min-2026-107385, BIT-mysql-client-2026-107385, GHSA-r3rv-jm3r-62q2.