# CVE-2026-107395: Indico: Missing access check in legacy session export API


- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 8 Oct 2026
- **Updated:** 9 Oct 2026
- **Also known as:** GHSA-6p4f-j8j6-463q, PYSEC-2026-4226

## What is CVE-2026-107395?

CVE-2026-107395 is a medium-severity vulnerability in indico, published on 8 Oct 2026. 

### Official description

Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. Prior to 3.3.13, an authenticated user can misuse the legacy session export API to retrieve details for a restricted session without access to that session, as long as the containing event is accessible. The missing access check can disclose session metadata such as the title, description, and conveners. This issue is fixed in version 3.3.13.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-107395?

3 open source packages ship an affected version, including indico.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `indico` | PyPI | All versions | 3.3.13 |
| `indico` | PyPI | All versions | 3.3.13 |
| `indico` | PyPI | All versions | 3.3.13 |

## How do I fix CVE-2026-107395?

Upgrade indico to 3.3.13 or later.

## Is CVE-2026-107395 being exploited?

There is no known exploitation of CVE-2026-107395 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-107395 and fix it if it is affected.

What it is: CVE-2026-107395 is a medium-severity vulnerability in indico, published on 8 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-107395 in the wild and no public exploit code.

Affected packages and fixed versions:
- indico (PyPI): affected all versions; fixed in 3.3.13
- indico (PyPI): affected all versions; fixed in 3.3.13
- indico (PyPI): affected all versions; fixed in 3.3.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-107395/ (Markdown: https://insights.sbomify.com/CVE-2026-107395/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-107395
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-107395
- OSV: https://osv.dev/vulnerability/CVE-2026-107395

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-107395/
Summaries are generated and may contain mistakes; the official description above is the record.
