# CVE-2026-107396: Indico: Cross-Site-Scripting in link fields

> Attackers can inject malicious JavaScript via crafted URLs in event fields, allowing script execution in victims' browsers within the Indico origin.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Oct 2026
- **Updated:** 9 Oct 2026
- **Also known as:** GHSA-c4wc-ggrj-jg9v, PYSEC-2026-4227

## What is CVE-2026-107396?

CVE-2026-107396 is a medium-severity cross-site scripting vulnerability in indico, published on 8 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. Prior to 3.3.13, users who can manage events or create content, including speakers who can upload material, can store crafted javascript URLs in fields that accept custom URLs. A user who follows one of these URLs can execute attacker-controlled script in the user's browser in the Indico origin. This issue is fixed in version 3.3.13.

Weakness: CWE-692 (Incomplete Denylist to Cross-Site Scripting)

## Which versions are affected by CVE-2026-107396?

3 open source packages ship an affected version, including indico.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `indico` | PyPI | All versions | 3.3.13 |
| `indico` | PyPI | All versions | 3.3.13 |
| `indico` | PyPI | All versions | 3.3.13 |

## How do I fix CVE-2026-107396?

Upgrade indico to 3.3.13 or later.

## Is CVE-2026-107396 being exploited?

There is no known exploitation of CVE-2026-107396 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-107396 and fix it if it is affected.

What it is: CVE-2026-107396 is a medium-severity cross-site scripting vulnerability in indico, published on 8 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-107396 in the wild and no public exploit code.

Affected packages and fixed versions:
- indico (PyPI): affected all versions; fixed in 3.3.13
- indico (PyPI): affected all versions; fixed in 3.3.13
- indico (PyPI): affected all versions; fixed in 3.3.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-107396/ (Markdown: https://insights.sbomify.com/CVE-2026-107396/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-107396
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-107396
- OSV: https://osv.dev/vulnerability/CVE-2026-107396

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-107396/
Summaries are generated and may contain mistakes; the official description above is the record.
