# CVE-2026-107397: Indico: Cross-Site-Scripting in minutes editor

> Attackers can inject malicious scripts into event minutes, executing code in viewers' browsers during concurrent edits, requiring an upgrade to Indico.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** GHSA-cw24-x4mj-fw3q, PYSEC-2026-4228

## What is CVE-2026-107397?

CVE-2026-107397 is a medium-severity cross-site scripting vulnerability in indico, published on 8 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. Prior to 3.3.13, users who can create content, including speakers who can create minutes, can store crafted HTML in event minutes. When concurrent edits are made to the same minutes, the minute editor conflict UI can execute attacker-controlled script in the viewer's browser in the Indico origin. This issue is fixed in version 3.3.13.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-107397?

3 open source packages ship an affected version, including indico.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `indico` | PyPI | All versions | 3.3.13 |
| `indico` | PyPI | All versions | 3.3.13 |
| `indico` | PyPI | All versions | 3.3.13 |

## How do I fix CVE-2026-107397?

Upgrade indico to 3.3.13 or later.

## Is CVE-2026-107397 being exploited?

There is no known exploitation of CVE-2026-107397 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-107397 and fix it if it is affected.

What it is: CVE-2026-107397 is a medium-severity cross-site scripting vulnerability in indico, published on 8 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-107397 in the wild and no public exploit code.

Affected packages and fixed versions:
- indico (PyPI): affected all versions; fixed in 3.3.13
- indico (PyPI): affected all versions; fixed in 3.3.13
- indico (PyPI): affected all versions; fixed in 3.3.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-107397/ (Markdown: https://insights.sbomify.com/CVE-2026-107397/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-107397
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-107397
- OSV: https://osv.dev/vulnerability/CVE-2026-107397

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-107397/
Summaries are generated and may contain mistakes; the official description above is the record.
