# CVE-2026-107399: Mechanize sends credential headers to another origin after a meta refresh

> Mechanize leaks sensitive headers to external origins during meta refreshes if follow_meta_refresh is enabled, allowing attackers to steal tokens or cookies.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2026
- **Updated:** 14 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-107399, GHSA-c6rp-p8xm-4q9f, UBUNTU-CVE-2026-107399

## What is CVE-2026-107399?

CVE-2026-107399 is a medium-severity vulnerability in sparklemotion mechanize, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Mechanize library is used for automating interaction with websites. Prior to 2.14.1, Mechanize applies no origin trust boundary in Mechanize::HTTP::Agent#response_follow_meta_refresh when Mechanize#follow_meta_refresh is enabled. A page containing a meta refresh to another origin causes headers configured through Mechanize#request_headers= to be reapplied to the refresh request, allowing an attacker who controls content in the crawl to capture bearer tokens or session cookies. The default configuration is not affected because follow_meta_refresh is false, and the exposure is limited to caller-supplied default headers. This issue is fixed in version 2.14.1.

Weakness: CWE-522 (Insufficiently Protected Credentials), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-107399?

2 open source packages ship an affected version, including mechanize.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mechanize` | RubyGems | All versions | 2.14.1 |
| `mechanize` | RubyGems | All versions | 2.14.1 |

## How do I fix CVE-2026-107399?

Upgrade mechanize to 2.14.1 or later.

## Is CVE-2026-107399 being exploited?

There is no known exploitation of CVE-2026-107399 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-107399 and fix it if it is affected.

What it is: CVE-2026-107399 is a medium-severity vulnerability in sparklemotion mechanize, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-107399 in the wild and no public exploit code.

Affected packages and fixed versions:
- mechanize (RubyGems): affected all versions; fixed in 2.14.1
- mechanize (RubyGems): affected all versions; fixed in 2.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-107399/ (Markdown: https://insights.sbomify.com/CVE-2026-107399/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-107399
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-107399
- OSV: https://osv.dev/vulnerability/CVE-2026-107399

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-107399/
Summaries are generated and may contain mistakes; the official description above is the record.
