{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-10758 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-10758 is a high-severity vulnerability in Esri Lerc, published on 25 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-10758 and fix it if it is affected.\n\nWhat it is: CVE-2026-10758 is a high-severity vulnerability in Esri Lerc, published on 25 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-10758 in the wild and no public exploit code.\n\nAffected product: Esri Lerc. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-10758/ (Markdown: https://insights.sbomify.com/CVE-2026-10758/index.md)","id":"CVE-2026-10758","markdown":"https://insights.sbomify.com/CVE-2026-10758/index.md","name":"CVE-2026-10758","record":{"aliases":["AZL-105081","GHSA-cw29-mw7w-pj37","GHSA-gfc2-qmh7-jf3x","RHSA-2026:45254"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Esri Lerc library","requires_auth":"none","summary":"A remote attacker can cause a denial of service by sending crafted imagery to applications using the Esri Lerc library.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Esri","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"Esri LERC is an open-source image or raster format which supports rapid encoding and decoding for any pixel type. A Heap based Out-of-Bounds Write via Integer Overflow in LERC versions 4.1.0 and earlier may allow a remote, unauthenticated attacker who can pass specifically crafted attacker controlled imagery to an application that uses LERC to crash the application, leading to a denial of service.","ecosystems":["Red Hat:hummingbird:1"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Esri Lerc has a security vulnerability","id":"CVE-2026-10758","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"integer_overflow","year":"2026"},"n_packages":4,"n_references":1,"next":{"headline":"BUG-000171040 Portal for ArcGIS has a security vulnerability","id":"CVE-2026-10759"},"packages":[{"ecosystem":"Red Hat:hummingbird:1","fixed":["0:4.2.0-1.hum1"],"introduced":["0"],"last_affected":[],"package":"liblerc","purl":"pkg:rpm/redhat/liblerc","source":"RHSA-2026:45254"},{"ecosystem":"Red Hat:hummingbird:1","fixed":["0:4.2.0-1.hum1"],"introduced":["0"],"last_affected":[],"package":"liblerc-devel","purl":"pkg:rpm/redhat/liblerc-devel","source":"RHSA-2026:45254"},{"ecosystem":"Red Hat:hummingbird:1","fixed":["0:4.2.0-1.hum1"],"introduced":["0"],"last_affected":[],"package":"mingw32-liblerc","purl":"pkg:rpm/redhat/mingw32-liblerc","source":"RHSA-2026:45254"},{"ecosystem":"Red Hat:hummingbird:1","fixed":["0:4.2.0-1.hum1"],"introduced":["0"],"last_affected":[],"package":"mingw64-liblerc","purl":"pkg:rpm/redhat/mingw64-liblerc","source":"RHSA-2026:45254"}],"prev":{"headline":"BUG-000187511 - ArcGIS Server has a security vulnerability.","id":"CVE-2026-10757"},"products":["Lerc"],"published":"2026-09-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-26","vendors":["Esri"]},"summary":"A remote attacker can cause a denial of service by sending crafted imagery to applications using the Esri Lerc library.","url":"https://insights.sbomify.com/CVE-2026-10758/"}