# CVE-2026-107685: WebSocket sessions do not verify TLS certificates, exposing API keys and OAuth tokens to on-path attackers


- **Severity:** Critical 9.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** EEF-CVE-2026-107685, GHSA-6vww-5m28-f26v, GHSA-w53j-6pxf-r2vw

## What is CVE-2026-107685?

CVE-2026-107685 is a critical vulnerability in agentjido req_llm, published on 23 Oct 2026. 

### Official description

Improper Certificate Validation vulnerability in the WebSocket streaming client in agentjido req_llm allows an on-path attacker to read and modify OpenAI WebSocket sessions, including the authorization bearer token, via a TLS certificate the client does not trust. ReqLLM.Streaming.WebSocketSession.Client.start/3 in lib/req_llm/streaming/web_socket_session/client.ex starts WebSockex without TLS options, and WebSockex defaults to insecure: true, which connects with verify: :verify_none. The option allowlist also drops any caller-supplied cacerts or ssl_options, so an application cannot turn verification on.

The OpenAI Responses, Realtime, and Codex WebSocket paths reach this client and send the API key or OAuth access token in the authorization header. HTTP streaming through Finch and the HTTP/2 duplex session through Mint verify certificates and are not affected.

This issue affects req_llm: from 1.9.0 before 1.29.0.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-107685?

1 open source package ship an affected version, including req_llm.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `req_llm` | Hex | From 1.9.0 | 1.29.0 |

## How do I fix CVE-2026-107685?

Upgrade req_llm to 1.29.0 or later.

## Is CVE-2026-107685 being exploited?

There is no known exploitation of CVE-2026-107685 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-107685 and fix it if it is affected.

What it is: CVE-2026-107685 is a critical vulnerability in agentjido req_llm, published on 23 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-107685 in the wild and no public exploit code.

Affected packages and fixed versions:
- req_llm (Hex): affected from 1.9.0; fixed in 1.29.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-107685/ (Markdown: https://insights.sbomify.com/CVE-2026-107685/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-107685
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-107685
- OSV: https://osv.dev/vulnerability/CVE-2026-107685

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-107685/
Summaries are generated and may contain mistakes; the official description above is the record.
