# CVE-2026-107715: Mechanize sends credential headers to another host after an HTTP redirect

> Mechanize leaks credential headers to attacker-controlled hosts during redirects, allowing capture of bearer tokens or session cookies.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2026
- **Updated:** 9 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-107715, GHSA-2mwr-xjcg-37j7, UBUNTU-CVE-2026-107715

## What is CVE-2026-107715?

CVE-2026-107715 is a medium-severity vulnerability in sparklemotion mechanize, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Mechanize library is used for automating interaction with websites. Prior to 2.14.1, Mechanize sends caller-supplied credential headers to a different host after an HTTP redirect. Mechanize#request_headers= is reapplied by Mechanize::HTTP::Agent#request_add_headers even after Mechanize::HTTP::Agent#response_redirect strips per-request headers, and the protected header lists omit Proxy-Authorization and Cookie2. An attacker who controls a redirect target can capture bearer tokens or session cookies supplied through request_headers= or the per-request headers argument, while Mechanize#cookie_jar and Mechanize::HTTP::AuthStore are not affected. This issue is fixed in version 2.14.1.

Weakness: CWE-522 (Insufficiently Protected Credentials), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-107715?

2 open source packages ship an affected version, including mechanize.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mechanize` | RubyGems | All versions | 2.14.1 |
| `mechanize` | RubyGems | All versions | 2.14.1 |

## How do I fix CVE-2026-107715?

Upgrade mechanize to 2.14.1 or later.

## Is CVE-2026-107715 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-107715 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-107715 and fix it if it is affected.

What it is: CVE-2026-107715 is a medium-severity vulnerability in sparklemotion mechanize, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-107715 exists.

Affected packages and fixed versions:
- mechanize (RubyGems): affected all versions; fixed in 2.14.1
- mechanize (RubyGems): affected all versions; fixed in 2.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-107715/ (Markdown: https://insights.sbomify.com/CVE-2026-107715/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-107715
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-107715
- OSV: https://osv.dev/vulnerability/CVE-2026-107715

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-107715/
Summaries are generated and may contain mistakes; the official description above is the record.
