{"answers":{"affected":"3 open source packages ship an affected version, including banks.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-107717 exists.","fix":"Upgrade banks to 2.5.0 or later.","what":"CVE-2026-107717 is a medium-severity code injection vulnerability in masci banks, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-107717 and fix it if it is affected.\n\nWhat it is: CVE-2026-107717 is a medium-severity code injection vulnerability in masci banks, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-107717 exists.\n\nAffected packages and fixed versions:\n- banks (PyPI): affected all versions; fixed in 2.5.0\n- banks (PyPI): affected all versions; fixed in 2.5.0\n- banks (PyPI): affected all versions; fixed in 2.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-107717/ (Markdown: https://insights.sbomify.com/CVE-2026-107717/index.md)","id":"CVE-2026-107717","markdown":"https://insights.sbomify.com/CVE-2026-107717/index.md","name":"CVE-2026-107717","record":{"aliases":["GHSA-hmq2-7hp6-7crh","PYSEC-2026-4202"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Python LLM library","requires_auth":"none","summary":"Attackers can inject privileged chat messages via untrusted input, overriding LLM instructions and potentially executing code or bypassing security controls.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Banks generates meaningful LLM prompts using a simple template language. Prior to 2.5.0, Banks Prompt.chat_messages() attempts to parse every line of rendered template output as ChatMessage JSON. When an application renders untrusted data and passes the returned ChatMessage objects to an LLM provider, attacker-controlled JSON can cross the prompt boundary and become a system, assistant, or tool message because ChatMessage.role accepts arbitrary strings. This can override application instructions, alter the intended prompt structure, or confuse downstream tool and message handling. This issue is fixed in version 2.5.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Banks: User-controlled prompt input can be parsed as privileged chat messages","id":"CVE-2026-107717","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"AdonisJS: Unencoded route parameters can produce open redirects","id":"CVE-2026-107718"},"packages":[{"ecosystem":"PyPI","fixed":["2.5.0"],"introduced":["0"],"last_affected":[],"package":"banks","purl":null,"source":"GHSA-hmq2-7hp6-7crh"},{"ecosystem":"PyPI","fixed":["2.5.0"],"introduced":["0"],"last_affected":[],"package":"banks","purl":"pkg:pypi/banks","source":"GHSA-hmq2-7hp6-7crh"},{"ecosystem":"PyPI","fixed":["2.5.0"],"introduced":["0"],"last_affected":[],"package":"banks","purl":"pkg:pypi/banks","source":"PYSEC-2026-4202"}],"prev":{"headline":"Banks: Symlink traversal and arbitrary file disclosure/overwrite in DirectoryPromptRegistry","id":"CVE-2026-107716"},"products":["banks"],"published":"2026-10-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-13","vendors":["masci"]},"summary":"Attackers can inject privileged chat messages via untrusted input, overriding LLM instructions and potentially executing code or bypassing security controls.","url":"https://insights.sbomify.com/CVE-2026-107717/"}