# CVE-2026-107717: Banks: User-controlled prompt input can be parsed as privileged chat messages

> Attackers can inject privileged chat messages via untrusted input, overriding LLM instructions and potentially executing code or bypassing security controls.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** GHSA-hmq2-7hp6-7crh, PYSEC-2026-4202

## What is CVE-2026-107717?

CVE-2026-107717 is a medium-severity code injection vulnerability in masci banks, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Banks generates meaningful LLM prompts using a simple template language. Prior to 2.5.0, Banks Prompt.chat_messages() attempts to parse every line of rendered template output as ChatMessage JSON. When an application renders untrusted data and passes the returned ChatMessage objects to an LLM provider, attacker-controlled JSON can cross the prompt boundary and become a system, assistant, or tool message because ChatMessage.role accepts arbitrary strings. This can override application instructions, alter the intended prompt structure, or confuse downstream tool and message handling. This issue is fixed in version 2.5.0.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-107717?

3 open source packages ship an affected version, including banks.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `banks` | PyPI | All versions | 2.5.0 |
| `banks` | PyPI | All versions | 2.5.0 |
| `banks` | PyPI | All versions | 2.5.0 |

## How do I fix CVE-2026-107717?

Upgrade banks to 2.5.0 or later.

## Is CVE-2026-107717 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-107717 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-107717 and fix it if it is affected.

What it is: CVE-2026-107717 is a medium-severity code injection vulnerability in masci banks, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-107717 exists.

Affected packages and fixed versions:
- banks (PyPI): affected all versions; fixed in 2.5.0
- banks (PyPI): affected all versions; fixed in 2.5.0
- banks (PyPI): affected all versions; fixed in 2.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-107717/ (Markdown: https://insights.sbomify.com/CVE-2026-107717/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-107717
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-107717
- OSV: https://osv.dev/vulnerability/CVE-2026-107717

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-107717/
Summaries are generated and may contain mistakes; the official description above is the record.
