# CVE-2026-107719: fast-jwt: Verifier cache accepts expired JWTs without iat.

> An attacker can replay cached JWTs to extend access beyond expiration if caching is enabled and tokens lack iat claims.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2026
- **Updated:** 9 Oct 2026
- **Also known as:** GHSA-x937-hj6v-793p

## What is CVE-2026-107719?

CVE-2026-107719 is a medium-severity vulnerability in nearform fast-jwt, published on 8 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

fast-jwt provides fast JSON Web Token (JWT) implementation. Prior to 6.3.4, the fast-jwt createVerifier cache can continue accepting a previously valid, signed JWT after its exp time when caching is enabled and the token has exp but no iat. In src/verifier.js, cacheSet derives the exp cache deadline only when iat is present, so the cache falls back to cacheTTL, and a later cache hit returns the saved payload before verifyToken rechecks expiration. An attacker who can replay the same cached bearer token can extend access until the cache entry expires, but cannot forge a token through this issue. This issue is fixed in version 6.3.4.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2026-107719?

2 open source packages ship an affected version, including fast-jwt.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fast-jwt` | npm | All versions | 6.3.4 |
| `fast-jwt` | npm | All versions | 6.3.4 |

## How do I fix CVE-2026-107719?

Upgrade fast-jwt to 6.3.4 or later.

## Is CVE-2026-107719 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-107719 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-107719 and fix it if it is affected.

What it is: CVE-2026-107719 is a medium-severity vulnerability in nearform fast-jwt, published on 8 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-107719 exists.

Affected packages and fixed versions:
- fast-jwt (npm): affected all versions; fixed in 6.3.4
- fast-jwt (npm): affected all versions; fixed in 6.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-107719/ (Markdown: https://insights.sbomify.com/CVE-2026-107719/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-107719
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-107719
- OSV: https://osv.dev/vulnerability/CVE-2026-107719

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-107719/
Summaries are generated and may contain mistakes; the official description above is the record.
