# CVE-2026-107720: fast-jwt: createVerifier accepts unsigned JWTs when key is '' or null and algorithms is explicitly set

> Attackers can bypass authentication by submitting unsigned JWTs when the verifier is configured with an empty key and explicit algorithms.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2026
- **Updated:** 9 Oct 2026
- **Also known as:** GHSA-8wpc-h4q6-8fxv

## What is CVE-2026-107720?

CVE-2026-107720 is a high-severity authentication bypass vulnerability in nearform fast-jwt, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fast-jwt provides fast JSON Web Token (JWT) implementation. Prior to 6.3.1, fast-jwt createVerifier accepts an unsigned JWT when key is an empty string or null and algorithms is a non-empty allowlist. Falsy synchronous keys bypass prepareKeyOrSecret, allowedAlgorithms remains active, hasKey is false, and the empty signature avoids the verifySignature gate. An attacker can therefore submit a token containing arbitrary claims without possessing a signing key, resulting in authentication or authorization bypass. Claim validators still run, and non-empty keys, an empty key without algorithms, and the async key resolver path do not have this behavior. This issue is fixed in version 6.3.1.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-107720?

2 open source packages ship an affected version, including fast-jwt.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fast-jwt` | npm | All versions | 6.3.1 |
| `fast-jwt` | npm | All versions | 6.3.1 |

## How do I fix CVE-2026-107720?

Upgrade fast-jwt to 6.3.1 or later.

## Is CVE-2026-107720 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-107720 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-107720 and fix it if it is affected.

What it is: CVE-2026-107720 is a high-severity authentication bypass vulnerability in nearform fast-jwt, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-107720 exists.

Affected packages and fixed versions:
- fast-jwt (npm): affected all versions; fixed in 6.3.1
- fast-jwt (npm): affected all versions; fixed in 6.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-107720/ (Markdown: https://insights.sbomify.com/CVE-2026-107720/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-107720
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-107720
- OSV: https://osv.dev/vulnerability/CVE-2026-107720

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-107720/
Summaries are generated and may contain mistakes; the official description above is the record.
