{"answers":{"affected":"2 open source packages ship an affected version, including fast-jwt.","exploited":"There is no known exploitation of CVE-2026-107721 in the wild and no public exploit code.","fix":"Upgrade fast-jwt to 6.3.0 or later.","what":"CVE-2026-107721 is a medium-severity vulnerability in nearform fast-jwt, published on 8 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-107721 and fix it if it is affected.\n\nWhat it is: CVE-2026-107721 is a medium-severity vulnerability in nearform fast-jwt, published on 8 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-107721 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fast-jwt (npm): affected all versions; fixed in 6.3.0\n- fast-jwt (npm): affected all versions; fixed in 6.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-107721/ (Markdown: https://insights.sbomify.com/CVE-2026-107721/index.md)","id":"CVE-2026-107721","markdown":"https://insights.sbomify.com/CVE-2026-107721/index.md","name":"CVE-2026-107721","record":{"aliases":["GHSA-687g-22h4-j4w4"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js JWT library","requires_auth":"high_privilege","summary":"Attackers can bypass JWT expiration and not-before checks if clockTolerance is set to Infinity, allowing use of invalid tokens.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-682","name":"Incorrect Calculation"},{"id":"CWE-613","name":"DEPRECATED: Insufficient Session Expiration"}],"description":"fast-jwt provides fast JSON Web Token (JWT) implementation. Prior to 6.3.0, fast-jwt createVerifier accepts Infinity for clockTolerance because its option validation checks type and negativity but not finiteness. In validateClaimDateValue, infinite positive and negative modifiers make exp and nbf comparisons always pass, allowing expired or not-yet-active tokens to be accepted. The verifier cache also derives infinite bounds, so entries created under this configuration can remain valid until eviction. Exploitation requires an application administrator or equivalent configuration path to set clockTolerance to Infinity. This issue is fixed in version 6.3.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"fast-jwt clockTolerance: Infinity silently bypasses both exp and nbf validation (and persists in the verifier cache)","id":"CVE-2026-107721","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"fast-jwt: Incomplete patch of CVE-2026-34950: Non-whitespace key-prefix re-enables RSA→HS256 algorithm confusion","id":"CVE-2026-107722"},"packages":[{"ecosystem":"npm","fixed":["6.3.0"],"introduced":["0"],"last_affected":[],"package":"fast-jwt","purl":null,"source":"GHSA-687g-22h4-j4w4"},{"ecosystem":"npm","fixed":["6.3.0"],"introduced":["0"],"last_affected":[],"package":"fast-jwt","purl":"pkg:npm/fast-jwt","source":"GHSA-687g-22h4-j4w4"}],"prev":{"headline":"fast-jwt: createVerifier accepts unsigned JWTs when key is '' or null and algorithms is explicitly set","id":"CVE-2026-107720"},"products":["fast-jwt"],"published":"2026-10-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-09","vendors":["nearform"]},"summary":"Attackers can bypass JWT expiration and not-before checks if clockTolerance is set to Infinity, allowing use of invalid tokens.","url":"https://insights.sbomify.com/CVE-2026-107721/"}