# CVE-2026-107721: fast-jwt clockTolerance: Infinity silently bypasses both exp and nbf validation (and persists in the verifier cache)

> Attackers can bypass JWT expiration and not-before checks if clockTolerance is set to Infinity, allowing use of invalid tokens.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2026
- **Updated:** 9 Oct 2026
- **Also known as:** GHSA-687g-22h4-j4w4

## What is CVE-2026-107721?

CVE-2026-107721 is a medium-severity vulnerability in nearform fast-jwt, published on 8 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

fast-jwt provides fast JSON Web Token (JWT) implementation. Prior to 6.3.0, fast-jwt createVerifier accepts Infinity for clockTolerance because its option validation checks type and negativity but not finiteness. In validateClaimDateValue, infinite positive and negative modifiers make exp and nbf comparisons always pass, allowing expired or not-yet-active tokens to be accepted. The verifier cache also derives infinite bounds, so entries created under this configuration can remain valid until eviction. Exploitation requires an application administrator or equivalent configuration path to set clockTolerance to Infinity. This issue is fixed in version 6.3.0.

Weakness: CWE-682 (Incorrect Calculation), CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2026-107721?

2 open source packages ship an affected version, including fast-jwt.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fast-jwt` | npm | All versions | 6.3.0 |
| `fast-jwt` | npm | All versions | 6.3.0 |

## How do I fix CVE-2026-107721?

Upgrade fast-jwt to 6.3.0 or later.

## Is CVE-2026-107721 being exploited?

There is no known exploitation of CVE-2026-107721 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-107721 and fix it if it is affected.

What it is: CVE-2026-107721 is a medium-severity vulnerability in nearform fast-jwt, published on 8 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-107721 in the wild and no public exploit code.

Affected packages and fixed versions:
- fast-jwt (npm): affected all versions; fixed in 6.3.0
- fast-jwt (npm): affected all versions; fixed in 6.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-107721/ (Markdown: https://insights.sbomify.com/CVE-2026-107721/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-107721
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-107721
- OSV: https://osv.dev/vulnerability/CVE-2026-107721

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-107721/
Summaries are generated and may contain mistakes; the official description above is the record.
