# CVE-2026-107722: fast-jwt: Incomplete patch of CVE-2026-34950: Non-whitespace key-prefix re-enables RSA→HS256 algorithm confusion

> Attackers can bypass authentication by exploiting algorithm confusion in fast-jwt when public keys have non-whitespace prefixes, allowing HS256 token forgery.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** GHSA-ww5h-9m49-7xx4

## What is CVE-2026-107722?

CVE-2026-107722 is a critical authentication bypass vulnerability in nearform fast-jwt, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fast-jwt provides fast JSON Web Token (JWT) implementation. From 6.2.0 until 6.3.0, fast-jwt can misclassify RSA public-key text as an HMAC secret when the key has non-whitespace content before its PEM header. In src/crypto.js, performDetectPublicKeyAlgorithms trims whitespace but publicKeyPemMatcher remains start-anchored, so comments, control characters, zero-width characters, or wrapper text can prevent PEM detection and reach the HMAC fallback. An attacker who knows the public key bytes can sign arbitrary HS256 claims with that public material when HS256 is inferred or allowed, resulting in authentication or authorization bypass. An asymmetric-only algorithm allowlist prevents the attack. This issue is fixed in version 6.3.0.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2026-107722?

2 open source packages ship an affected version, including fast-jwt.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fast-jwt` | npm | From 6.2.0 | 6.3.0 |
| `fast-jwt` | npm | From 6.2.0 | 6.3.0 |

## How do I fix CVE-2026-107722?

Upgrade fast-jwt to 6.3.0 or later.

## Is CVE-2026-107722 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-107722 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-107722 and fix it if it is affected.

What it is: CVE-2026-107722 is a critical authentication bypass vulnerability in nearform fast-jwt, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-107722 exists.

Affected packages and fixed versions:
- fast-jwt (npm): affected from 6.2.0; fixed in 6.3.0
- fast-jwt (npm): affected from 6.2.0; fixed in 6.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-107722/ (Markdown: https://insights.sbomify.com/CVE-2026-107722/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-107722
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-107722
- OSV: https://osv.dev/vulnerability/CVE-2026-107722

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-107722/
Summaries are generated and may contain mistakes; the official description above is the record.
