{"answers":{"affected":"2 open source packages ship an affected version, including fast-jwt.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-107723 exists.","fix":"Upgrade fast-jwt to 6.3.0 or later.","what":"CVE-2026-107723 is a high-severity vulnerability in nearform fast-jwt, published on 8 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-107723 and fix it if it is affected.\n\nWhat it is: CVE-2026-107723 is a high-severity vulnerability in nearform fast-jwt, published on 8 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-107723 exists.\n\nAffected packages and fixed versions:\n- fast-jwt (npm): affected all versions; fixed in 6.3.0\n- fast-jwt (npm): affected all versions; fixed in 6.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-107723/ (Markdown: https://insights.sbomify.com/CVE-2026-107723/index.md)","id":"CVE-2026-107723","markdown":"https://insights.sbomify.com/CVE-2026-107723/index.md","name":"CVE-2026-107723","record":{"aliases":["GHSA-5hjw-83fp-phq9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"JWT library","requires_auth":"low_privilege","summary":"Attackers can bypass JWT claim validations like expiry and issuer by using a JSON array payload, affecting applications using fast-jwt.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-1287","name":"Improper Validation of Specified Type of Input"}],"description":"fast-jwt provides fast JSON Web Token (JWT) implementation. Prior to 6.3.0, fast-jwt createVerifier accepts a validly signed JWT whose payload is a JSON array because src/decoder.js checks that the payload is an object but does not reject arrays. The claim validator loop then finds no named exp, nbf, iss, aud, sub, jti, or nonce properties and silently skips those configured checks, returning the array as a successfully verified payload. An attacker who can produce or influence a validly signed token may bypass expiry, issuer, audience, subject, revocation, and replay protections. The opt-in requiredClaims option can block missing claims, and signature verification itself is not bypassed. This issue is fixed in version 6.3.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"fast-jwt : Silent claim-validator bypass when JWT payload is a JSON array","id":"CVE-2026-107723","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"fast-jwt treats raw public JWK JSON as an HMAC secret, enabling HS256 token forgery","id":"CVE-2026-107724"},"packages":[{"ecosystem":"npm","fixed":["6.3.0"],"introduced":["0"],"last_affected":[],"package":"fast-jwt","purl":null,"source":"GHSA-5hjw-83fp-phq9"},{"ecosystem":"npm","fixed":["6.3.0"],"introduced":["0"],"last_affected":[],"package":"fast-jwt","purl":"pkg:npm/fast-jwt","source":"GHSA-5hjw-83fp-phq9"}],"prev":{"headline":"fast-jwt: Incomplete patch of CVE-2026-34950: Non-whitespace key-prefix re-enables RSA→HS256 algorithm confusion","id":"CVE-2026-107722"},"products":["fast-jwt"],"published":"2026-10-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-14","vendors":["nearform"]},"summary":"Attackers can bypass JWT claim validations like expiry and issuer by using a JSON array payload, affecting applications using fast-jwt.","url":"https://insights.sbomify.com/CVE-2026-107723/"}