# CVE-2026-107723: fast-jwt : Silent claim-validator bypass when JWT payload is a JSON array

> Attackers can bypass JWT claim validations like expiry and issuer by using a JSON array payload, affecting applications using fast-jwt.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2026
- **Updated:** 14 Oct 2026
- **Also known as:** GHSA-5hjw-83fp-phq9

## What is CVE-2026-107723?

CVE-2026-107723 is a high-severity vulnerability in nearform fast-jwt, published on 8 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

fast-jwt provides fast JSON Web Token (JWT) implementation. Prior to 6.3.0, fast-jwt createVerifier accepts a validly signed JWT whose payload is a JSON array because src/decoder.js checks that the payload is an object but does not reject arrays. The claim validator loop then finds no named exp, nbf, iss, aud, sub, jti, or nonce properties and silently skips those configured checks, returning the array as a successfully verified payload. An attacker who can produce or influence a validly signed token may bypass expiry, issuer, audience, subject, revocation, and replay protections. The opt-in requiredClaims option can block missing claims, and signature verification itself is not bypassed. This issue is fixed in version 6.3.0.

Weakness: CWE-1287 (Improper Validation of Specified Type of Input)

## Which versions are affected by CVE-2026-107723?

2 open source packages ship an affected version, including fast-jwt.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fast-jwt` | npm | All versions | 6.3.0 |
| `fast-jwt` | npm | All versions | 6.3.0 |

## How do I fix CVE-2026-107723?

Upgrade fast-jwt to 6.3.0 or later.

## Is CVE-2026-107723 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-107723 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-107723 and fix it if it is affected.

What it is: CVE-2026-107723 is a high-severity vulnerability in nearform fast-jwt, published on 8 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-107723 exists.

Affected packages and fixed versions:
- fast-jwt (npm): affected all versions; fixed in 6.3.0
- fast-jwt (npm): affected all versions; fixed in 6.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-107723/ (Markdown: https://insights.sbomify.com/CVE-2026-107723/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-107723
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-107723
- OSV: https://osv.dev/vulnerability/CVE-2026-107723

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-107723/
Summaries are generated and may contain mistakes; the official description above is the record.
