# CVE-2026-107724: fast-jwt treats raw public JWK JSON as an HMAC secret, enabling HS256 token forgery

> Attackers can forge HS256 tokens by using public JWK JSON as an HMAC secret if HS256 is allowed, bypassing authentication checks.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2026
- **Updated:** 9 Oct 2026
- **Also known as:** GHSA-g3jj-5cmm-3hxx

## What is CVE-2026-107724?

CVE-2026-107724 is a high-severity vulnerability in nearform fast-jwt, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fast-jwt provides fast JSON Web Token (JWT) implementation. In 6.2.4, fast-jwt can classify raw serialized public JWK or JWKS JSON as an HMAC secret because src/crypto.js performDetectPublicKeyAlgorithms treats non-PEM strings as symmetric key material. If HS256 is explicitly allowed or inferred, an attacker who knows the exact serialized public-key bytes can use those bytes as an HMAC key and create a token containing arbitrary claims that createVerifier accepts. Serialization ordering or whitespace differences can prevent exploitation, and applications using supported PEM keys with an asymmetric-only algorithm allowlist are not affected. This issue is fixed in version 6.3.0.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2026-107724?

2 open source packages ship an affected version, including fast-jwt.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fast-jwt` | npm | From 6.2.4 | 6.3.0 |
| `fast-jwt` | npm | From 6.2.4 | 6.3.0 |

## How do I fix CVE-2026-107724?

Upgrade fast-jwt to 6.3.0 or later.

## Is CVE-2026-107724 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-107724 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-107724 and fix it if it is affected.

What it is: CVE-2026-107724 is a high-severity vulnerability in nearform fast-jwt, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-107724 exists.

Affected packages and fixed versions:
- fast-jwt (npm): affected from 6.2.4; fixed in 6.3.0
- fast-jwt (npm): affected from 6.2.4; fixed in 6.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-107724/ (Markdown: https://insights.sbomify.com/CVE-2026-107724/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-107724
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-107724
- OSV: https://osv.dev/vulnerability/CVE-2026-107724

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-107724/
Summaries are generated and may contain mistakes; the official description above is the record.
