CVE-2026-107727 Strawberry legacy graphql-ws retains naturally completed subscription slots

Low 3.7 Published Updated

Attackers can exhaust subscription slots on persistent WebSocket connections in Strawberry GraphQL, blocking legitimate operations when per-connection limits are configured.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-107727?

CVE-2026-107727 is a low-severity denial of service vulnerability in strawberry-graphql strawberry, published on 8 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Strawberry GraphQL is a library for creating GraphQL APIs. From 0.312.3 until 0.327.2, the legacy graphql-ws subscription handler in strawberry/subscriptions/protocols/graphql_ws/handlers.py does not remove naturally completed operations from self.tasks and self.subscriptions. When max_subscriptions_per_connection is configured, a client on a persistent WebSocket connection can use distinct operation IDs for one-shot subscriptions to fill the connection's configured slots even after those subscriptions send complete, causing later legitimate operations on that connection to be rejected with Subscription limit reached. The modern graphql-transport-ws protocol and deployments without the configured per-connection cap are not affected. This issue is fixed in version 0.327.2.

Weakness: CWE-400

Which versions are affected by CVE-2026-107727?

3 open source packages ship an affected version, including strawberry-graphql.

PackageAffectedFixed in
strawberry-graphql PyPIFrom 0.312.30.327.2
strawberry-graphql PyPIFrom 0.312.30.327.2
strawberry-graphql PyPIFrom 0.312.30.327.2

How do I fix CVE-2026-107727?

Upgrade strawberry-graphql to 0.327.2 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-107727 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-107727 exists.

Sources

Also known as GHSA-m952-2w3f-6r8h, PYSEC-2026-4302.

Is CVE-2026-107727 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free