# CVE-2026-107820: x64dbg-MCP Server vulnerable to pre-authentication denial of service through Content-Length integer overflow

> Unauthenticated attackers can crash the x64dbg debugger by sending a large Content-Length header, causing a denial of service.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Oct 2026
- **Updated:** 13 Oct 2026

## What is CVE-2026-107820?

CVE-2026-107820 is a medium-severity vulnerability in duty1g x64dbg-mcp-server, published on 9 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

x64dbg-MCP Server is a native Model Context Protocol (MCP) plugin for x64dbg that exposes the debugger's full functionality over HTTP. Prior to 1.2, src/core/mcp_server.zig parses an unbounded Content-Length value in parseContentLength() and uses it in unchecked usize addition in wsRecv() before token authentication. The server listens on 0.0.0.0 by default in affected versions. An unauthenticated network client can supply a near-maximum Content-Length value to trigger a runtime integer-overflow panic in Debug and ReleaseSafe builds, terminating the entire x64dbg process and its live debugging session. The overflowed value is used only in a comparison, so the impact is limited to denial of service rather than memory corruption or code execution. This issue is fixed in version 1.2.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-107820?


## How do I fix CVE-2026-107820?

No fix has been published for CVE-2026-107820 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-107820 being exploited?

There is no known exploitation of CVE-2026-107820 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-107820 and fix it if it is affected.

What it is: CVE-2026-107820 is a medium-severity vulnerability in duty1g x64dbg-mcp-server, published on 9 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-107820 in the wild and no public exploit code.

Affected product: duty1g x64dbg-mcp-server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-107820/ (Markdown: https://insights.sbomify.com/CVE-2026-107820/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-107820
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-107820
- OSV: https://osv.dev/vulnerability/CVE-2026-107820

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-107820/
Summaries are generated and may contain mistakes; the official description above is the record.
