# CVE-2026-107850: Contao: Improper access control in the preview links module

> Non-admin users can view unpublished pages and other users' preview links due to improper access control in the preview module.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** GHSA-q6wp-fr43-gm9v

## What is CVE-2026-107850?

CVE-2026-107850 is a medium-severity missing authorization vulnerability in contao, published on 9 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Contao is an Open Source CMS. From version 5.7.1 until 5.7.12, core-bundle/config/services.yaml registers the preview access voter as Contao\CoreBundle\Security\Voter\DataContainer\PreviewAccessVoter although the shipped class is PreviewVoter. Symfony therefore omits voter autoconfiguration and removes the private service, so PreviewVoter::hasAccess() never enforces ownership. A non-admin backend user with the preview_link module can list every tl_preview_link record, obtain signed share URLs created by other users, and use them to view unpublished pages with showUnpublished despite lacking page permission. The advisory does not establish editing or deletion of foreign links. This issue is fixed in version 5.7.12.

Weakness: CWE-862 (Missing Authorization), CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-107850?

2 open source packages ship an affected version, including contao/core-bundle.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `contao/core-bundle` | Packagist | From 5.7.1 | 5.7.12 |
| `contao/core-bundle` | Packagist | From 5.7.1 | 5.7.12 |

## How do I fix CVE-2026-107850?

Upgrade contao/core-bundle to 5.7.12 or later.

## Is CVE-2026-107850 being exploited?

There is no known exploitation of CVE-2026-107850 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-107850 and fix it if it is affected.

What it is: CVE-2026-107850 is a medium-severity missing authorization vulnerability in contao, published on 9 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-107850 in the wild and no public exploit code.

Affected packages and fixed versions:
- contao/core-bundle (Packagist): affected from 5.7.1; fixed in 5.7.12
- contao/core-bundle (Packagist): affected from 5.7.1; fixed in 5.7.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-107850/ (Markdown: https://insights.sbomify.com/CVE-2026-107850/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-107850
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-107850
- OSV: https://osv.dev/vulnerability/CVE-2026-107850

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-107850/
Summaries are generated and may contain mistakes; the official description above is the record.
