# CVE-2026-107851: Contao: Improper access control in the table access voter

> A low-privileged backend user can bypass access controls to read, create, update, or delete records in unauthorized tables due to flawed caching logic.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** GHSA-5974-gfqc-wrcm

## What is CVE-2026-107851?

CVE-2026-107851 is a medium-severity missing authorization vulnerability in contao, published on 9 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Contao is an Open Source CMS. From version 5.7.0 until 5.7.12, TableAccessVoter::hasAccessToModule() in core-bundle/src/Security/Voter/DataContainer/TableAccessVoter.php caches authorization decisions using only $tokenHash, a hash of the user's security token, and omits the table returned by getDataSource(). If one request first checks a table allowed to the user and then a different denied table, the voter can reuse the allowed result, while DefaultDataContainerVoter can convert an incorrect abstention into a grant. A low-privileged backend user can consequently read, create, update, or delete records in tables outside assigned module permissions, including tables containing member or newsletter-subscriber data. This issue is fixed in version 5.7.12.

Weakness: CWE-863 (Incorrect Authorization), CWE-524 (Use of Cache Containing Sensitive Information)

## Which versions are affected by CVE-2026-107851?

2 open source packages ship an affected version, including contao/core-bundle.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `contao/core-bundle` | Packagist | From 5.7.0 | 5.7.12 |
| `contao/core-bundle` | Packagist | From 5.7.0 | 5.7.12 |

## How do I fix CVE-2026-107851?

Upgrade contao/core-bundle to 5.7.12 or later.

## Is CVE-2026-107851 being exploited?

There is no known exploitation of CVE-2026-107851 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-107851 and fix it if it is affected.

What it is: CVE-2026-107851 is a medium-severity missing authorization vulnerability in contao, published on 9 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-107851 in the wild and no public exploit code.

Affected packages and fixed versions:
- contao/core-bundle (Packagist): affected from 5.7.0; fixed in 5.7.12
- contao/core-bundle (Packagist): affected from 5.7.0; fixed in 5.7.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-107851/ (Markdown: https://insights.sbomify.com/CVE-2026-107851/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-107851
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-107851
- OSV: https://osv.dev/vulnerability/CVE-2026-107851

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-107851/
Summaries are generated and may contain mistakes; the official description above is the record.
