# CVE-2026-108106: Xerial snappy-java before 1.1.10.9 Unbounded Memory Allocation Denial of Service

> Attackers can cause denial of service in applications using snappy-java by triggering unbounded memory allocation through crafted compressed input.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** CLEANSTART-2026-BS90242, DEBIAN-CVE-2026-108106, ECHO-0bfa-518c-ee16, GHSA-q233-g92q-qxp6, UBUNTU-CVE-2026-108106

## What is CVE-2026-108106?

CVE-2026-108106 is a high-severity denial of service vulnerability in xerial snappy-java, published on 9 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Xerial snappy-java before 1.1.10.9 contains an unbounded memory allocation vulnerability that allows attackers to exhaust JVM memory by declaring a large uncompressed length in compressed input. Attackers can supply a few crafted bytes to Snappy.uncompress, uncompressString, SnappyInputStream or SnappyFramedInputStream to force allocations up to 2 GB, causing OutOfMemoryError and denial of service.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value)

## Which versions are affected by CVE-2026-108106?

2 open source packages ship an affected version, including org.xerial.snappy:snappy-java.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xerial.snappy:snappy-java` | Maven | All versions | 1.1.10.9 |
| `org.xerial.snappy:snappy-java` | Maven | All versions | 1.1.10.9 |

## How do I fix CVE-2026-108106?

Upgrade org.xerial.snappy:snappy-java to 1.1.10.9 or later.

## Is CVE-2026-108106 being exploited?

There is no known exploitation of CVE-2026-108106 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-108106 and fix it if it is affected.

What it is: CVE-2026-108106 is a high-severity denial of service vulnerability in xerial snappy-java, published on 9 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-108106 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xerial.snappy:snappy-java (Maven): affected all versions; fixed in 1.1.10.9
- org.xerial.snappy:snappy-java (Maven): affected all versions; fixed in 1.1.10.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-108106/ (Markdown: https://insights.sbomify.com/CVE-2026-108106/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-108106
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-108106
- OSV: https://osv.dev/vulnerability/CVE-2026-108106

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-108106/
Summaries are generated and may contain mistakes; the official description above is the record.
