CVE-2026-10813 LMCache KV Cache utils.py hex_hash_to_int16 weak hash
A weak hash function in LMCache allows local attackers to potentially bypass security checks, requiring high complexity to exploit.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-10813?
CVE-2026-10813 is a low-severity vulnerability in LMCache, published on 4 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
A flaw has been found in LMCache up to 0.5.4. This affects the function hex_hash_to_int16 of the file lmcache/integration/vllm/utils.py of the component KV Cache Handler. Executing a manipulation can lead to use of weak hash. The attack needs to be launched locally. The attack requires a high level of complexity. It is indicated that the exploitability is difficult. The exploit has been published and may be used. Upgrading to version 0.5.5 is able to mitigate this issue. This patch is called ce08eea76ce5898200efee55f4932fd07a7cabeb. It is suggested to upgrade the affected component. A contributor of the project confirms: "hex_hash_to_int16() was introduced in 0.3.1 (PR #882, commit f5174701). It is not present in 0.3.0, and it is still present in 0.4.7 through 0.5.4."
Which versions are affected by CVE-2026-10813?
3 open source packages ship an affected version, including lmcache.
| Package | Affected | Fixed in |
|---|---|---|
lmcache PyPI | All versions to 0.4.6 | None |
lmcache PyPI | All versions to 0.4.6 | None |
lmcache PyPI | All versions to 0.4.6 | None |
How do I fix CVE-2026-10813?
Upgrade to a fixed version.
Is CVE-2026-10813 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-10813 exists.
Sources
Also known as GHSA-3hh9-752g-5g22, MINI-cxxw-w693-346v, MINI-m9gr-xh23-q53v, PYSEC-2026-3480.