{"answers":{"affected":"3 open source packages ship an affected version, including lmcache.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-10813 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2026-10813 is a low-severity vulnerability in LMCache, published on 4 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-10813 and fix it if it is affected.\n\nWhat it is: CVE-2026-10813 is a low-severity vulnerability in LMCache, published on 4 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-10813 exists.\n\nAffected packages and fixed versions:\n- lmcache (PyPI): affected all versions up to 0.4.6; no fix listed\n- lmcache (PyPI): affected all versions up to 0.4.6; no fix listed\n- lmcache (PyPI): affected all versions up to 0.4.6; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-10813/ (Markdown: https://insights.sbomify.com/CVE-2026-10813/index.md)","id":"CVE-2026-10813","markdown":"https://insights.sbomify.com/CVE-2026-10813/index.md","name":"CVE-2026-10813","record":{"aliases":["GHSA-3hh9-752g-5g22","MINI-cxxw-w693-346v","MINI-m9gr-xh23-q53v","PYSEC-2026-3480"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"LMCache KV Cache library","requires_auth":"low_privilege","summary":"A weak hash function in LMCache allows local attackers to potentially bypass security checks, requiring high complexity to exploit.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":2,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-328","name":"Use of Weak Hash"},{"id":"CWE-327","name":"Use of a Broken or Risky Cryptographic Algorithm"}],"description":"A flaw has been found in LMCache up to 0.5.4. This affects the function hex_hash_to_int16 of the file lmcache/integration/vllm/utils.py of the component KV Cache Handler. Executing a manipulation can lead to use of weak hash. The attack needs to be launched locally. The attack requires a high level of complexity. It is indicated that the exploitability is difficult. The exploit has been published and may be used. Upgrading to version 0.5.5 is able to mitigate this issue. This patch is called ce08eea76ce5898200efee55f4932fd07a7cabeb. It is suggested to upgrade the affected component. A contributor of the project confirms: \"hex_hash_to_int16() was introduced in 0.3.1 (PR #882, commit f5174701). It is not present in 0.3.0, and it is still present in 0.4.7 through 0.5.4.\"","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"LMCache KV Cache utils.py hex_hash_to_int16 weak hash","id":"CVE-2026-10813","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"weak_cryptography","year":"2026"},"n_packages":3,"n_references":9,"next":{"headline":"milvus-io milvus Grantee ID Hash kv_catalog.go weak hash","id":"CVE-2026-10814"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["0.4.6"],"package":"lmcache","purl":null,"source":"GHSA-3hh9-752g-5g22"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["0.4.6"],"package":"lmcache","purl":"pkg:pypi/lmcache","source":"GHSA-3hh9-752g-5g22"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["0.4.6"],"package":"lmcache","purl":"pkg:pypi/lmcache","source":"PYSEC-2026-3480"}],"prev":{"headline":"zilliztech GPTCache Cache Key pre.py BufferedReader.peek weak hash","id":"CVE-2026-10812"},"products":["LMCache"],"published":"2026-06-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-17","vendors":["n/a"]},"summary":"A weak hash function in LMCache allows local attackers to potentially bypass security checks, requiring high complexity to exploit.","url":"https://insights.sbomify.com/CVE-2026-10813/"}