# CVE-2026-108258: Shiny for Python - Path traversal in bookmark restore

> An unauthenticated attacker can exploit path traversal in Shiny for Python to read or expose arbitrary server files via bookmark restore.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** GHSA-47c3-hpmg-7j6p, PYSEC-2026-4300

## What is CVE-2026-108258?

CVE-2026-108258 is a medium-severity path traversal vulnerability in posit-dev py-shiny, published on 9 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Shiny for Python is a framework for building interactive web applications in Python. From 1.4.0 until 1.6.4, bookmark restore accepts a client-supplied state_id and joins it into the server-side shiny_bookmarks directory without validating that it is a single safe path segment. An unauthenticated request can use parent-directory segments or an absolute path to make the server open input.json and values.json outside the bookmark store, even when bookmark_store is set to disable. In applications configured with bookmark_store set to server and using ui.input_file(), the restore handler can additionally copy and expose an attacker-selected file from an attacker-selected directory. This issue is fixed in version 1.6.4.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-108258?

3 open source packages ship an affected version, including shiny.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shiny` | PyPI | From 1.4.0 | 1.6.4 |
| `shiny` | PyPI | From 1.4.0 | 1.6.4 |
| `shiny` | PyPI | From 1.4.0 | 1.6.4 |

## How do I fix CVE-2026-108258?

Upgrade shiny to 1.6.4 or later.

## Is CVE-2026-108258 being exploited?

There is no known exploitation of CVE-2026-108258 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-108258 and fix it if it is affected.

What it is: CVE-2026-108258 is a medium-severity path traversal vulnerability in posit-dev py-shiny, published on 9 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-108258 in the wild and no public exploit code.

Affected packages and fixed versions:
- shiny (PyPI): affected from 1.4.0; fixed in 1.6.4
- shiny (PyPI): affected from 1.4.0; fixed in 1.6.4
- shiny (PyPI): affected from 1.4.0; fixed in 1.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-108258/ (Markdown: https://insights.sbomify.com/CVE-2026-108258/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-108258
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-108258
- OSV: https://osv.dev/vulnerability/CVE-2026-108258

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-108258/
Summaries are generated and may contain mistakes; the official description above is the record.
