# CVE-2026-108264: Code injection in wizarr

> Authenticated users can execute arbitrary Python code via Server-Side Template Injection in Wizarr wizard steps, leading to remote code execution and credential disclosure.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** GHSA-h9rv-mxh2-35f3

## What is CVE-2026-108264?

CVE-2026-108264 is a critical code injection vulnerability in wizarrrr wizarr, published on 9 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Wizarr is an advanced user invitation and management system for Jellyfin, Plex, Emby, and other media servers. Prior to 2026.9.1, wizard step Markdown supplied through the editor or imported bundles was evaluated by app/blueprints/wizard/routes.py in the application's non-sandboxed Jinja2 environment with application globals exposed. An authenticated user able to create steps, or an administrator importing an untrusted bundle through POST /settings/wizard/import, could execute arbitrary Python when GET /wizard/{server}/{idx} rendered the stored step; app/jinja_filters.py and app/services/wizard_widgets.py contained additional evaluation sinks. This could execute operating-system commands as the application user, disclose the Flask SECRET_KEY, access connected service credentials and the database, and produce stored cross-site scripting. This issue is fixed in 2026.9.1.

Weakness: CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2026-108264?


## How do I fix CVE-2026-108264?

No fix has been published for CVE-2026-108264 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-108264 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-108264 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-108264 and fix it if it is affected.

What it is: CVE-2026-108264 is a critical code injection vulnerability in wizarrrr wizarr, published on 9 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-108264 exists.

Affected product: wizarrrr wizarr. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-108264/ (Markdown: https://insights.sbomify.com/CVE-2026-108264/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-108264
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-108264
- OSV: https://osv.dev/vulnerability/CVE-2026-108264

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-108264/
Summaries are generated and may contain mistakes; the official description above is the record.
