CVE-2026-108357 PhpSpreadsheet: XmlScanner Bypass via Double-Encoded unentity() TOCTOU Allows XXE and Denial of Service
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2026-108357?
CVE-2026-108357 is a high-severity vulnerability in PHPOffice PhpSpreadsheet, published on 22 Oct 2026.
Official description
PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. From 3.3.0 until 3.10.8 and 5.10.0, Reader\Xml passes stored SpreadsheetML XML through XmlScanner::scan in Xml::canRead and Xml::trySimpleXMLLoadStringPrivate, while Xml::unentity decodes numeric entities only after each DOCTYPE pattern check. A double-encoded less-than character is reduced by the first callback to another encoded character and by the second callback to a literal less-than sign, so SimpleXML receives an unchecked DOCTYPE and entity declaration. Processing attacker-controlled SpreadsheetML XML can cause entity-expansion denial of service and can permit local file access or SSRF on PHP before 8.0 or when LIBXML_NOENT is enabled. This issue is fixed in versions 3.10.8 and 5.10.0.
Which versions are affected by CVE-2026-108357?
4 open source packages ship an affected version, including phpoffice/phpspreadsheet.
| Package | Affected | Fixed in |
|---|---|---|
phpoffice/phpspreadsheet Packagist | From 3.3.0 | 3.10.8 |
phpoffice/phpspreadsheet Packagist | From 3.3.0 | 3.10.8 |
phpoffice/phpspreadsheet Packagist | From 4.0.0 | 5.10.0 |
phpoffice/phpspreadsheet Packagist | From 4.0.0 | 5.10.0 |
How do I fix CVE-2026-108357?
Upgrade phpoffice/phpspreadsheet to a fixed version for your release line: 3.10.8 or 5.10.0.
Is CVE-2026-108357 being exploited?
There is no known exploitation of CVE-2026-108357 in the wild and no public exploit code.
Sources
Also known as GHSA-rxj4-h86g-25gc.