CVE-2026-108358 PhpSpreadsheet: XmlScanner Bypass via ISO-2022 Escape Sequences Allows XXE and Denial of Service
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2026-108358?
CVE-2026-108358 is a high-severity vulnerability in PHPOffice PhpSpreadsheet, published on 22 Oct 2026.
Official description
PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. Prior to 1.30.7, 2.1.19, 2.4.8, 3.10.8, and 5.10.0, XmlScanner::scan in src/PhpSpreadsheet/Reader/Security/XmlScanner.php uses a DOCTYPE detection pattern that accounts for NUL-byte interleaving but not ISO-2022 escape sequences in XLSX XML parts. The escape sequences prevent the scanner from matching the declaration, and XML charset normalization then removes the escape bytes before parsing, exposing a valid DOCTYPE and entity definitions. Processing an attacker-controlled XLSX can therefore cause entity-expansion denial of service on supported PHP versions and can permit local file access or SSRF on PHP before 8.0 or when LIBXML_NOENT is enabled. This issue is fixed in versions 1.30.7, 2.1.19, 2.4.8, 3.10.8, and 5.10.0.
Which versions are affected by CVE-2026-108358?
10 open source packages ship an affected version, including phpoffice/phpspreadsheet.
| Package | Affected | Fixed in |
|---|---|---|
phpoffice/phpspreadsheet Packagist | All versions | 1.30.7 |
phpoffice/phpspreadsheet Packagist | All versions | 1.30.7 |
phpoffice/phpspreadsheet Packagist | From 2.0.0 | 2.1.19 |
phpoffice/phpspreadsheet Packagist | From 2.0.0 | 2.1.19 |
phpoffice/phpspreadsheet Packagist | From 2.2.0 | 2.4.8 |
phpoffice/phpspreadsheet Packagist | From 2.2.0 | 2.4.8 |
4 more packages
phpoffice/phpspreadsheet Packagist | From 3.3.0 | 3.10.8 |
phpoffice/phpspreadsheet Packagist | From 3.3.0 | 3.10.8 |
phpoffice/phpspreadsheet Packagist | From 4.0.0 | 5.10.0 |
phpoffice/phpspreadsheet Packagist | From 4.0.0 | 5.10.0 |
How do I fix CVE-2026-108358?
Upgrade phpoffice/phpspreadsheet to a fixed version for your release line: 1.30.7, 2.1.19, 2.4.8 or 3.10.8.
Is CVE-2026-108358 being exploited?
There is no known exploitation of CVE-2026-108358 in the wild and no public exploit code.
Sources
Also known as CLSA-2026-1793283095, GHSA-3x94-m842-937c.