CVE-2026-108360 PhpSpreadsheet: SSRF whitelist bypass via unre-validated HTTP redirect in Drawing::setPath external image loading
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2026-108360?
CVE-2026-108360 is a medium-severity vulnerability in PHPOffice PhpSpreadsheet, published on 22 Oct 2026.
Official description
PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. Prior to 1.30.7, 2.1.19, 2.4.8, 3.10.8, and 5.10.0, Worksheet\Drawing::setPath validates only the initial external-image URL with setIsWhitelisted when setAllowExternalImages is enabled. The HTTP stream context permits PHP to follow a redirect without applying the callback to the redirected URL, so a permitted image host can redirect the server to an internal address and cause a blind GET request. The response body is not returned to the attacker because the reader validates the downloaded content as an image and removes the temporary file, but internal GET-driven endpoints, network reachability, and cloud metadata endpoints may be reached. This issue is fixed in versions 1.30.7, 2.1.19, 2.4.8, 3.10.8, and 5.10.0.
Which versions are affected by CVE-2026-108360?
10 open source packages ship an affected version, including phpoffice/phpspreadsheet.
| Package | Affected | Fixed in |
|---|---|---|
phpoffice/phpspreadsheet Packagist | All versions | 1.30.7 |
phpoffice/phpspreadsheet Packagist | All versions | 1.30.7 |
phpoffice/phpspreadsheet Packagist | From 2.0.0 | 2.1.19 |
phpoffice/phpspreadsheet Packagist | From 2.0.0 | 2.1.19 |
phpoffice/phpspreadsheet Packagist | From 2.2.0 | 2.4.8 |
phpoffice/phpspreadsheet Packagist | From 2.2.0 | 2.4.8 |
4 more packages
phpoffice/phpspreadsheet Packagist | From 3.3.0 | 3.10.8 |
phpoffice/phpspreadsheet Packagist | From 3.3.0 | 3.10.8 |
phpoffice/phpspreadsheet Packagist | From 4.0.0 | 5.10.0 |
phpoffice/phpspreadsheet Packagist | From 4.0.0 | 5.10.0 |
How do I fix CVE-2026-108360?
Upgrade phpoffice/phpspreadsheet to a fixed version for your release line: 1.30.7, 2.1.19, 2.4.8 or 3.10.8.
Is CVE-2026-108360 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-108360 exists.
Sources
Also known as GHSA-2phh-27fw-q4gc.