# CVE-2026-108360: PhpSpreadsheet: SSRF whitelist bypass via unre-validated HTTP redirect in Drawing::setPath external image loading


- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 22 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-2phh-27fw-q4gc

## What is CVE-2026-108360?

CVE-2026-108360 is a medium-severity vulnerability in PHPOffice PhpSpreadsheet, published on 22 Oct 2026. 

### Official description

PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. Prior to 1.30.7, 2.1.19, 2.4.8, 3.10.8, and 5.10.0, Worksheet\Drawing::setPath validates only the initial external-image URL with setIsWhitelisted when setAllowExternalImages is enabled. The HTTP stream context permits PHP to follow a redirect without applying the callback to the redirected URL, so a permitted image host can redirect the server to an internal address and cause a blind GET request. The response body is not returned to the attacker because the reader validates the downloaded content as an image and removes the temporary file, but internal GET-driven endpoints, network reachability, and cloud metadata endpoints may be reached. This issue is fixed in versions 1.30.7, 2.1.19, 2.4.8, 3.10.8, and 5.10.0.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-108360?

10 open source packages ship an affected version, including phpoffice/phpspreadsheet.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpoffice/phpspreadsheet` | Packagist | All versions | 1.30.7 |
| `phpoffice/phpspreadsheet` | Packagist | All versions | 1.30.7 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.0.0 | 2.1.19 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.0.0 | 2.1.19 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.2.0 | 2.4.8 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.2.0 | 2.4.8 |
| `phpoffice/phpspreadsheet` | Packagist | From 3.3.0 | 3.10.8 |
| `phpoffice/phpspreadsheet` | Packagist | From 3.3.0 | 3.10.8 |
| `phpoffice/phpspreadsheet` | Packagist | From 4.0.0 | 5.10.0 |
| `phpoffice/phpspreadsheet` | Packagist | From 4.0.0 | 5.10.0 |

## How do I fix CVE-2026-108360?

Upgrade phpoffice/phpspreadsheet to a fixed version for your release line: 1.30.7, 2.1.19, 2.4.8 or 3.10.8.

## Is CVE-2026-108360 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-108360 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-108360 and fix it if it is affected.

What it is: CVE-2026-108360 is a medium-severity vulnerability in PHPOffice PhpSpreadsheet, published on 22 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-108360 exists.

Affected packages and fixed versions:
- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.30.7
- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.30.7
- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.19
- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.19
- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.4.8
- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.4.8
- phpoffice/phpspreadsheet (Packagist): affected from 3.3.0; fixed in 3.10.8
- phpoffice/phpspreadsheet (Packagist): affected from 3.3.0; fixed in 3.10.8
- phpoffice/phpspreadsheet (Packagist): affected from 4.0.0; fixed in 5.10.0
- phpoffice/phpspreadsheet (Packagist): affected from 4.0.0; fixed in 5.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-108360/ (Markdown: https://insights.sbomify.com/CVE-2026-108360/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-108360
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-108360
- OSV: https://osv.dev/vulnerability/CVE-2026-108360

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-108360/
Summaries are generated and may contain mistakes; the official description above is the record.
