{"answers":{"affected":"2 open source packages ship an affected version, including loopx.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-108372 exists.","fix":"Upgrade loopx to 0.4.5 or later.","what":"CVE-2026-108372 is a high-severity vulnerability in huangruiteng loopx, published on 16 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-108372 and fix it if it is affected.\n\nWhat it is: CVE-2026-108372 is a high-severity vulnerability in huangruiteng loopx, published on 16 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-108372 exists.\n\nAffected packages and fixed versions:\n- loopx (PyPI): affected from 0.0.1; fixed in 0.4.5\n- loopx (PyPI): affected from 0.0.1; fixed in 0.4.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-108372/ (Markdown: https://insights.sbomify.com/CVE-2026-108372/index.md)","id":"CVE-2026-108372","markdown":"https://insights.sbomify.com/CVE-2026-108372/index.md","name":"CVE-2026-108372","record":{"aliases":["GHSA-vx2m-gpq4-8j5q"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"LoopX status server","requires_auth":"none","summary":"A permissive CORS policy in LoopX allows remote attackers to read control-plane state and private files via cross-origin requests from a victim's browser.","user_interaction":"required","vuln_class":"misconfiguration"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-942","name":"Permissive Cross-domain Security Policy with Untrusted Domains"},{"id":"CWE-346","name":"Origin Validation Error"}],"description":"Open and provider-neutral, LoopX is a lightweight state kernel and local-first control plane for loop engineering. From version 0.0.1 until 0.4.5, `loopx serve-status` in `loopx/status_server.py` uses `StatusRequestHandler._send_json()` and `do_OPTIONS()` to send `Access-Control-Allow-Origin: *` for unauthenticated responses on predictable loopback ports. A remote attacker can cause an operator who visits attacker-controlled web content to issue cross-origin requests to `GET /status.json`, `GET /review-material?goal_id=...\u0026path=...`, `GET /`, and `POST /control-plane/configure-goal/dry-run`, exposing control-plane state, goal and run information, local absolute paths, private Markdown files below registered goal roots, and dry-run configuration projections. The affected routes do not provide cross-origin writes or arbitrary-file access. This issue is fixed in version 0.4.5.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"LoopX serve-status permissive CORS policy exposes control-plane state and private Markdown files","id":"CVE-2026-108372","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"misconfiguration","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"ERPNext: Unauthorised access to financial data due to missing validation","id":"CVE-2026-108373"},"packages":[{"ecosystem":"PyPI","fixed":["0.4.5"],"introduced":["0.0.1"],"last_affected":[],"package":"loopx","purl":null,"source":"GHSA-vx2m-gpq4-8j5q"},{"ecosystem":"PyPI","fixed":["0.4.5"],"introduced":["0.0.1"],"last_affected":[],"package":"loopx","purl":"pkg:pypi/loopx","source":"GHSA-vx2m-gpq4-8j5q"}],"prev":{"headline":"easy.jobs \u003c= 2.8.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'icon' Block Attribute","id":"CVE-2026-108366"},"products":["loopx"],"published":"2026-10-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-21","vendors":["huangruiteng"]},"summary":"A permissive CORS policy in LoopX allows remote attackers to read control-plane state and private files via cross-origin requests from a victim's browser.","url":"https://insights.sbomify.com/CVE-2026-108372/"}