# CVE-2026-108374: ERPNext: Unauthorised status modification due to missing validation

> Low-privileged users can modify data beyond their permissions due to missing authorization checks on status modification endpoints.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Oct 2026
- **Updated:** 19 Oct 2026

## What is CVE-2026-108374?

CVE-2026-108374 is a high-severity missing authorization vulnerability in frappe erpnext, published on 16 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ERPNext is a free and open source Enterprise Resource Planning tool. Prior to 15.121.0 and 16.34.0, certain endpoints for status modification fail to enforce proper authorization checks. A low-privileged authenticated user can invoke state-changing whitelisted methods without required write, submit, cancel, document, or role checks. This allows the user to modify data beyond the user's permitted role. This issue is fixed in versions 15.121.0 and 16.34.0.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-108374?


## How do I fix CVE-2026-108374?

No fix has been published for CVE-2026-108374 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-108374 being exploited?

There is no known exploitation of CVE-2026-108374 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-108374 and fix it if it is affected.

What it is: CVE-2026-108374 is a high-severity missing authorization vulnerability in frappe erpnext, published on 16 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-108374 in the wild and no public exploit code.

Affected product: frappe erpnext. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-108374/ (Markdown: https://insights.sbomify.com/CVE-2026-108374/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-108374
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-108374
- OSV: https://osv.dev/vulnerability/CVE-2026-108374

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-108374/
Summaries are generated and may contain mistakes; the official description above is the record.
