{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-108541 exists.","fix":"No fix has been published for CVE-2026-108541 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-108541 is a medium-severity SQL injection vulnerability in highwarden Super Store Finder, published on 11 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-108541 and fix it if it is affected.\n\nWhat it is: CVE-2026-108541 is a medium-severity SQL injection vulnerability in highwarden Super Store Finder, published on 11 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-108541 exists.\n\nAffected product: highwarden Super Store Finder. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-108541/ (Markdown: https://insights.sbomify.com/CVE-2026-108541/index.md)","id":"CVE-2026-108541","markdown":"https://insights.sbomify.com/CVE-2026-108541/index.md","name":"CVE-2026-108541","record":{"aliases":["GHSA-5949-23g3-9j6v"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Super Store Finder","requires_auth":"low_privilege","summary":"Remote attackers can exploit SQL injection in Super Store Finder via lat/lng parameters to read or modify database contents.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"},{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"A vulnerability has been found in highwarden Super Store Finder up to 3.8. Affected is an unknown function of the file /products/superstorefinder/index.php. The manipulation of the argument lat/lng leads to sql injection. Remote exploitation of the attack is possible. The exploit has been disclosed to the public and may be used. Upgrading to version 3.9 is able to address this issue. The affected component should be upgraded. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":null,"headline":"highwarden Super Store Finder index.php sql injection","id":"CVE-2026-108541","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"sql_injection","year":"2026"},"n_packages":0,"n_references":5,"next":{"headline":"021is elvix-sdk MCP Request index.ts server-side request forgery","id":"CVE-2026-108542"},"packages":[],"prev":{"headline":"OpenSpug File Transfer transfer os command injection","id":"CVE-2026-108540"},"products":["Super Store Finder"],"published":"2026-10-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-13","vendors":["highwarden"]},"summary":"Remote attackers can exploit SQL injection in Super Store Finder via lat/lng parameters to read or modify database contents.","url":"https://insights.sbomify.com/CVE-2026-108541/"}