{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-108574 exists.","fix":"No fix has been published for CVE-2026-108574 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-108574 is a medium-severity missing authorization vulnerability in BerriAI LiteLLM, published on 11 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-108574 and fix it if it is affected.\n\nWhat it is: CVE-2026-108574 is a medium-severity missing authorization vulnerability in BerriAI LiteLLM, published on 11 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-108574 exists.\n\nAffected product: BerriAI LiteLLM. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-108574/ (Markdown: https://insights.sbomify.com/CVE-2026-108574/index.md)","id":"CVE-2026-108574","markdown":"https://insights.sbomify.com/CVE-2026-108574/index.md","name":"CVE-2026-108574","record":{"aliases":["GHSA-wxjw-vcvf-mvw9"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"LiteLLM proxy","requires_auth":"low_privilege","summary":"Attackers can bypass authorization to view session spend logs by manipulating the session_id argument in LiteLLM.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-639","name":"Authorization Bypass Through User-Controlled Key"},{"id":"CWE-285","name":"Improper Authorization"}],"description":"A flaw has been found in BerriAI LiteLLM up to 1.95.0. Affected by this issue is the function ui_view_session_spend_logs of the file litellm/proxy/spend_tracking/spend_management_endpoints.py of the component Spend Tracking. Executing a manipulation of the argument session_id can lead to authorization bypass. It is possible to launch the attack remotely. The exploit has been published and may be used. Upgrading to version 1.96.0 can resolve this issue. This patch is called 722d9ffa4f6c5ae15702ab9ab2c5f6bf1688308b. The affected component should be upgraded.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"BerriAI LiteLLM Spend Tracking spend_management_endpoints.py ui_view_session_spend_logs authorization","id":"CVE-2026-108574","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":0,"n_references":7,"next":{"headline":"BerriAI LiteLLM Secret Resolution main.py get_secret improper authorization","id":"CVE-2026-108575"},"packages":[],"prev":{"headline":"Open Asset Import Library Assimp PLY File getNextBlock out-of-bounds","id":"CVE-2026-108573"},"products":["LiteLLM"],"published":"2026-10-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-13","vendors":["BerriAI"]},"summary":"Attackers can bypass authorization to view session spend logs by manipulating the session_id argument in LiteLLM.","url":"https://insights.sbomify.com/CVE-2026-108574/"}