# CVE-2026-108752: JupyterHub through 6.0.1 OAuth Client ID Collision via Unescaped Hyphen

> Authenticated users can overwrite other users' OAuth clients via hyphenated usernames, causing denial of service and token revocation.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** BIT-jupyterhub-2026-108752, DEBIAN-CVE-2026-108752, GHSA-h63v-vvgj-vrfh, MINI-6h9x-f9mm-ppcp, UBUNTU-CVE-2026-108752

## What is CVE-2026-108752?

CVE-2026-108752 is a low-severity vulnerability in jupyterhub, published on 11 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

JupyterHub through 6.0.1 contains an identifier collision vulnerability that allows authenticated users to overwrite another user's named-server OAuth client by registering a hyphenated username. Attackers holding a name like alice-prod can overwrite the client for alice's server prod, breaking OAuth login and revoking tokens by stopping their own server.

Weakness: CWE-694 (Use of Multiple Resources with Duplicate Identifier)

## Which versions are affected by CVE-2026-108752?

1 open source package ship an affected version, including jupyterhub.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyterhub` | Bitnami | All versions | 6.1.0 |

## How do I fix CVE-2026-108752?

Upgrade jupyterhub to 6.1.0 or later.

## Is CVE-2026-108752 being exploited?

There is no known exploitation of CVE-2026-108752 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-108752 and fix it if it is affected.

What it is: CVE-2026-108752 is a low-severity vulnerability in jupyterhub, published on 11 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-108752 in the wild and no public exploit code.

Affected packages and fixed versions:
- jupyterhub (Bitnami): affected all versions; fixed in 6.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-108752/ (Markdown: https://insights.sbomify.com/CVE-2026-108752/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-108752
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-108752
- OSV: https://osv.dev/vulnerability/CVE-2026-108752

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-108752/
Summaries are generated and may contain mistakes; the official description above is the record.
