# CVE-2026-108762: Apache Kylin: delete metadata backup path-confinement bypass

> Attackers can bypass path restrictions to delete arbitrary metadata backup files in Apache Kylin, primarily affecting publicly exposed services.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Oct 2026
- **Updated:** 19 Oct 2026
- **Also known as:** GHSA-f4w3-hpxf-cwrr

## What is CVE-2026-108762?

CVE-2026-108762 is a path traversal vulnerability in Apache Kylin, published on 19 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Path-confinement bypass during metadata backup deletion in Apache Kylin. Impact most to the kylin services that are directly exposed to public network, which is not common. In-house kylin deployments are mostly not impacted.

This issue affects Apache Kylin: from 4.0.0 through 5.0.4.

Users are recommended to upgrade to version 5.0.5, which fixes the issue.

## Which versions are affected by CVE-2026-108762?


## How do I fix CVE-2026-108762?

No fix has been published for CVE-2026-108762 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-108762 being exploited?

There is no known exploitation of CVE-2026-108762 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-108762 and fix it if it is affected.

What it is: CVE-2026-108762 is a path traversal vulnerability in Apache Kylin, published on 19 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-108762 in the wild and no public exploit code.

Affected product: Apache Kylin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-108762/ (Markdown: https://insights.sbomify.com/CVE-2026-108762/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-108762
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-108762
- OSV: https://osv.dev/vulnerability/CVE-2026-108762

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-108762/
Summaries are generated and may contain mistakes; the official description above is the record.
