{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-108764 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-108764 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-108764 is a server-side request forgery vulnerability in Apache Kylin, published on 19 Oct 2026. It can be exploited over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-108764 and fix it if it is affected.\n\nWhat it is: CVE-2026-108764 is a server-side request forgery vulnerability in Apache Kylin, published on 19 Oct 2026. It can be exploited over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-108764 in the wild and no public exploit code.\n\nAffected product: Apache Kylin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-108764/ (Markdown: https://insights.sbomify.com/CVE-2026-108764/index.md)","id":"CVE-2026-108764","markdown":"https://insights.sbomify.com/CVE-2026-108764/index.md","name":"CVE-2026-108764","record":{"aliases":["GHSA-c56v-vw4p-2ff3"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Kylin","requires_auth":"unknown","summary":"An SSRF vulnerability in Apache Kylin's job-driver UI proxy allows attackers to make arbitrary server-side requests, primarily affecting publicly exposed deployments.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Server-Side request forgery (SSRF) vulnerability in Apache Kylin. Impact most to the kylin job service that are directly exposed to public network, which is not common. In-house kylin deployments are mostly not impacted.\n\nThis issue affects Apache Kylin: from 4.0.0 through 5.0.4.\n\nUsers are recommended to upgrade to version 5.0.5, which fixes the issue.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Apache Kylin: job-driver UI proxy SSRF","id":"CVE-2026-108764","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"Apache Kylin: missing JDBC-config authorization","id":"CVE-2026-108766"},"packages":[],"prev":{"headline":"Wallet System for WooCommerce \u003c 2.8.2 - Subscriber+ KYC Document Overwrite via IDOR","id":"CVE-2026-108763"},"products":["Apache Kylin"],"published":"2026-10-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2026-10-19","vendors":["Apache Software Foundation"]},"summary":"An SSRF vulnerability in Apache Kylin's job-driver UI proxy allows attackers to make arbitrary server-side requests, primarily affecting publicly exposed deployments.","url":"https://insights.sbomify.com/CVE-2026-108764/"}